summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkenshen1122022-10-01 15:45:43 -0700
committerkenshen1122022-10-01 15:45:43 -0700
commit0f859332bcf25db883623794b2535aea3b97cc43 (patch)
treea9908b57546b6fe4b5397740466b1d98997bb44b
parentc898435a477f5adb757045a0d82e8d6a47e524cf (diff)
downloadaur-0f859332bcf25db883623794b2535aea3b97cc43.tar.gz
GS/wx: Change TriFilter name and move it to main renderer tab on wx.
-rw-r--r--.SRCINFO20
-rw-r--r--0001-QtHost.cpp-Fixed-Resources-dir.patch66
-rw-r--r--0002-Added-QT-Desktop-file.patch54
-rw-r--r--PKGBUILD38
4 files changed, 137 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e7e2dd1da88..541414079e5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pcsx2-git
pkgdesc = A Sony PlayStation 2 emulator
- pkgver = v1.7.0.dev.r4311.g173d62b1c
+ pkgver = 1.7.3357.r0.gd908fa5e3
pkgrel = 1
url = https://www.pcsx2.net
install = post.install
@@ -38,19 +38,11 @@ pkgbase = pcsx2-git
depends = zstd-cmake
provides = pcsx2-qt
conflicts = pcsx2
- source = git+https://github.com/kenshen112/pcsx2.git#branch=packages
- source = git+https://github.com/rtissera/libchdr.git
- source = git+https://github.com/google/googletest.git
- source = git+https://github.com/mozilla/cubeb.git
- source = git+https://github.com/KhronosGroup/glslang.git
- source = git+https://github.com/KhronosGroup/Vulkan-Headers.git
- source = git+https://github.com/fmtlib/fmt.git
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ source = git+https://github.com/PCSX2/pcsx2.git
+ source = 0001-QtHost.cpp-Fixed-Resources-dir.patch
+ source = 0002-Added-QT-Desktop-file.patch
sha256sums = SKIP
+ sha256sums = 88207a76ba366a343b5b9d8f90da0f44f2dd8145df0ad7582c223ff072528473
+ sha256sums = 33b3d6bde2c3973db918a28d4eacbef6e5db4be65856091988364f840d3702e1
pkgname = pcsx2-git
diff --git a/0001-QtHost.cpp-Fixed-Resources-dir.patch b/0001-QtHost.cpp-Fixed-Resources-dir.patch
new file mode 100644
index 000000000000..8d7041663d5a
--- /dev/null
+++ b/0001-QtHost.cpp-Fixed-Resources-dir.patch
@@ -0,0 +1,66 @@
+From 5df445e8989eecd8796ee3bbfa74c3f0997cf26d Mon Sep 17 00:00:00 2001
+From: kenshen112 <finalfantasytimothy@gmail.com>
+Date: Sun, 22 May 2022 16:44:51 -0700
+Subject: [PATCH 1/2] QtHost.cpp: Fixed Resources dir
+
+Fixed location of Resources Dir to proper usr/share location
+
+Fixed CMake to enable package mode
+---
+ .gitignore | 1 +
+ pcsx2-qt/CMakeLists.txt | 4 ++--
+ pcsx2/Frontend/CommonHost.cpp | 8 +++++---
+ 3 files changed, 8 insertions(+), 5 deletions(-)
+
+diff --git a/.gitignore b/.gitignore
+index b3091f88f..64b010d33 100644
+--- a/.gitignore
++++ b/.gitignore
+@@ -75,6 +75,7 @@ oprofile_data/
+ /bin/**/*.lib
+ /bin/**/*.pdb
+ /bin/pcsx2
++/bin/pcsx2-qt
+ /bin/PCSX2-linux.sh
+ /bin/*ReplayLoader
+ /bin/GS*.txt
+diff --git a/pcsx2-qt/CMakeLists.txt b/pcsx2-qt/CMakeLists.txt
+index 619cc3932..e44581147 100644
+--- a/pcsx2-qt/CMakeLists.txt
++++ b/pcsx2-qt/CMakeLists.txt
+@@ -4,8 +4,8 @@ set(CMAKE_AUTOUIC ON)
+
+ add_executable(pcsx2-qt)
+
+-if (PACKAGE_MODE)
+- message(FATAL_ERROR "Package mode is not supported for Qt builds.")
++if(PACKAGE_MODE)
++ install(TARGETS pcsx2-qt DESTINATION ${CMAKE_INSTALL_BINDIR})
+ else()
+ install(TARGETS pcsx2-qt DESTINATION ${CMAKE_SOURCE_DIR}/bin)
+ endif()
+diff --git a/pcsx2/Frontend/CommonHost.cpp b/pcsx2/Frontend/CommonHost.cpp
+index c6c536182..980d2b887 100644
+--- a/pcsx2/Frontend/CommonHost.cpp
++++ b/pcsx2/Frontend/CommonHost.cpp
+@@ -110,12 +110,14 @@ void CommonHost::SetAppRoot()
+
+ void CommonHost::SetResourcesDirectory()
+ {
+-#ifndef __APPLE__
++#ifdef __APPLE__
++ // On macOS, this is in the bundle resources directory.
++ EmuFolders::Resources = Path::Canonicalize(Path::Combine(EmuFolders::AppRoot, "../Resources"));
++#elif !defined(PCSX2_APP_DATADIR)
+ // On Windows/Linux, these are in the binary directory.
+ EmuFolders::Resources = Path::Combine(EmuFolders::AppRoot, "resources");
+ #else
+- // On macOS, this is in the bundle resources directory.
+- EmuFolders::Resources = Path::Canonicalize(Path::Combine(EmuFolders::AppRoot, "../Resources"));
++ EmuFolders::Resources = Path::Canonicalize(Path::Combine(EmuFolders::AppRoot, PCSX2_APP_DATADIR "/resources"));
+ #endif
+ }
+
+--
+2.37.3
+
diff --git a/0002-Added-QT-Desktop-file.patch b/0002-Added-QT-Desktop-file.patch
new file mode 100644
index 000000000000..447340480131
--- /dev/null
+++ b/0002-Added-QT-Desktop-file.patch
@@ -0,0 +1,54 @@
+From ee42d04c5d73b2e8f037cc18aceb044b2e87a5fb Mon Sep 17 00:00:00 2001
+From: kenshen112 <finalfantasytimothy@gmail.com>
+Date: Mon, 29 Aug 2022 16:43:14 -0700
+Subject: [PATCH 2/2] Added QT Desktop file
+
+---
+ CMakeLists.txt | 10 ++++++++++
+ linux_various/PCSX2.desktop.in | 2 +-
+ 2 files changed, 11 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 91a2c6756..8f18ecb99 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -15,6 +15,9 @@ set(TOP_CMAKE_WAS_SOURCED TRUE)
+ # set module path
+ set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
+
++#set executable name
++set(EXECUTEABLE "pcsx2")
++
+ # include some generic functions to ensure correctness of the env
+ include(Pcsx2Utils)
+
+@@ -66,6 +69,13 @@ if(PACKAGE_MODE)
+ else()
+ set(PCSX2_MENU_CATEGORIES "Game;Emulator;")
+ endif()
++
++ if(QT_BUILD)
++ set(EXECUTEABLE "pcsx2-qt")
++ else()
++ set(EXECUTEABLE "pcsx2")
++ endif()
++
+ configure_file("${CMAKE_SOURCE_DIR}/linux_various/PCSX2.desktop.in" "${CMAKE_BINARY_DIR}/linux_various/PCSX2.desktop" @ONLY)
+
+ INSTALL(FILES "${CMAKE_BINARY_DIR}/linux_various/PCSX2.desktop" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/applications")
+diff --git a/linux_various/PCSX2.desktop.in b/linux_various/PCSX2.desktop.in
+index 9dbc8f2d1..321453975 100644
+--- a/linux_various/PCSX2.desktop.in
++++ b/linux_various/PCSX2.desktop.in
+@@ -9,7 +9,7 @@ GenericName[zh_CN]=PlayStation 2 模拟器
+ Comment=Sony PlayStation 2 emulator
+ Comment[ru]=Эмулятор Sony PlayStation 2
+ Comment[zh_CN]=索尼 PlayStation 2 模拟器
+-Exec=env GDK_BACKEND=x11 MESA_NO_ERROR=1 pcsx2
++Exec=env GDK_BACKEND=x11 MESA_NO_ERROR=1 @EXECUTEABLE@
+ Icon=PCSX2
+ Keywords=game;emulator;
+ Categories=@PCSX2_MENU_CATEGORIES@
+--
+2.37.3
+
diff --git a/PKGBUILD b/PKGBUILD
index 62156e89366f..2a2a70da90a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Themaister <maister@archlinux.us>
pkgname=pcsx2-git
-pkgver=v1.7.0.dev.r4311.g173d62b1c
+pkgver=1.7.3357.r0.gd908fa5e3
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator'
arch=(x86_64)
@@ -61,42 +61,23 @@ provides=(pcsx2-qt)
conflicts=(pcsx2)
source=(
-git+https://github.com/kenshen112/pcsx2.git#branch=packages
-git+https://github.com/rtissera/libchdr.git
-git+https://github.com/google/googletest.git
-git+https://github.com/mozilla/cubeb.git
-git+https://github.com/KhronosGroup/glslang.git
-git+https://github.com/KhronosGroup/Vulkan-Headers.git
-git+https://github.com/fmtlib/fmt.git
-)
-
-sha256sums=(
-SKIP
-SKIP
-SKIP
-SKIP
-SKIP
-SKIP
-SKIP
+git+https://github.com/PCSX2/pcsx2.git
+0001-QtHost.cpp-Fixed-Resources-dir.patch
+0002-Added-QT-Desktop-file.patch
)
prepare()
{
cd $srcdir/pcsx2
- git submodule init
- git config submodule.3rdparty/libchdr/libchdr.url $srcdir/libchdr
- git config submodule.3rdparty/gtest.url $srcdir/googletest
- git config submodule.3rdparty/cubeb/cubeb.url $srcdir/cubeb
- git config submodule.3rdparty/glslang/glslang.url $srcdir/glslang
- git config submodule.3rdparty/vulkan-headers.url $srcdir/Vulkan-Headers
- git config submodule.3rdparty/fmt/fmt.url $srcdir/fmt
- git submodule update 3rdparty/libchdr/libchdr 3rdparty/gtest 3rdparty/cubeb/cubeb 3rdparty/glslang/glslang 3rdparty/vulkan-headers 3rdparty/fmt/fmt
+ git submodule update --init --recursive
+ patch --forward --strip=1 --input="${srcdir}/0001-QtHost.cpp-Fixed-Resources-dir.patch"
+ patch --forward --strip=1 --input="${srcdir}/0002-Added-QT-Desktop-file.patch"
}
pkgver()
{
cd $srcdir/pcsx2
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build()
@@ -125,3 +106,6 @@ package()
# vim: ts=2 sw=2 et:
+sha256sums=('SKIP'
+ '88207a76ba366a343b5b9d8f90da0f44f2dd8145df0ad7582c223ff072528473'
+ '33b3d6bde2c3973db918a28d4eacbef6e5db4be65856091988364f840d3702e1')