summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkenshen1122023-01-25 19:02:57 -0700
committerkenshen1122023-01-25 19:02:57 -0700
commitba9579b9897358322443e661ba0d60a5da388e86 (patch)
tree26975cd169465fce06bf4a4ce264ca4637c3da80
parentb0d9ca1cd9c70157a29e09e0ae5819500ecbfc7b (diff)
downloadaur-ba9579b9897358322443e661ba0d60a5da388e86.tar.gz
GHActions: Update release pipeline for MultiISA
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6675c783bf77..1c5e6fe04c97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pcsx2-git
pkgdesc = A Sony PlayStation 2 emulator
- pkgver = v1.7.3951.r0.gbf2ba3c4d
+ pkgver = v1.7.3959.r0.g2cd5ce6ae
pkgrel = 1
url = https://www.pcsx2.net
install = post.install
diff --git a/PKGBUILD b/PKGBUILD
index a693e05e4dd0..4e04f590da8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Themaister <maister@archlinux.us>
pkgname=pcsx2-git
-pkgver=v1.7.3951.r0.gbf2ba3c4d
+pkgver=v1.7.3959.r0.g2cd5ce6ae
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator'
arch=(x86_64)
@@ -83,8 +83,7 @@ pkgver()
build()
{
- cd $srcdir/pcsx2
- cd ..
+ cd $srcdir
mkdir -p build
cd build
@@ -105,12 +104,17 @@ build()
ninja -j$(nproc)
cd ..
- cp -r pcsx2/.github/workflows/scripts/linux/pcsx2-qt.desktop build/bin/PCSX2.desktop
}
package()
{
DESTDIR="${pkgdir}" cmake --install build
+
+ mkdir -p ${pkgdir}/usr/share/icons/hicolor/64x64/apps
+
+ cp -r pcsx2/.github/workflows/scripts/linux/pcsx2-qt.desktop build/bin/PCSX2.desktop
+ cp ${srcdir}/pcsx2/pcsx2/Resources/AppIcon64.png ${pkgdir}/usr/share/icons/hicolor/64x64/apps/PCSX2.png
+
}
# vim: ts=2 sw=2 et: