summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-04-07 23:15:37 +0200
committerMaxime Gauduin2017-04-07 23:15:37 +0200
commit3ffca2e815f01c5da05cccd3fc80272d4eac19b3 (patch)
treec6cd896b65de9415e4bc514cfafb1acd5add0703
parentaf99cb5d41380cbc4231db92512cba1b8690c47d (diff)
downloadaur-3ffca2e815f01c5da05cccd3fc80272d4eac19b3.tar.gz
pcsxr-git 1.9.93.r1697.6484236c-1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD34
2 files changed, 44 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48397b0e46ee..f631fd352af9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,36 @@
# Generated by mksrcinfo v8
-# Tue Aug 16 19:25:23 UTC 2016
+# Fri Apr 7 21:15:37 UTC 2017
pkgbase = pcsxr-git
pkgdesc = A Sony PlayStation emulator based on the PCSX-df Project
- pkgver = 1.9.93.r1662.fc378b6
+ pkgver = 1.9.93.r1697.6484236c
pkgrel = 1
url = http://pcsxr.codeplex.com/
arch = i686
arch = x86_64
license = GPL
+ makedepends = cmake
makedepends = git
makedepends = intltool
makedepends = mesa
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
depends = gtk3
- depends = libarchive
- depends = libcdio
+ depends = libgl
+ depends = libpulse
+ depends = libx11
+ depends = libxext
+ depends = libxtst
depends = libxv
+ depends = libxxf86vm
depends = sdl2
+ depends = zlib
+ depends = libarchive.so
+ depends = libavcodec.so
+ depends = libavformat.so
+ depends = libavutil.so
+ depends = libm.so
+ depends = libswresample.so
provides = pcsxr
conflicts = pcsxr
conflicts = pcsx-df
diff --git a/PKGBUILD b/PKGBUILD
index 543136f40a1f..d768c62d9320 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,17 @@
# Contributor: Infy <eugene.yudin@gmail.com>
pkgname=pcsxr-git
-pkgver=1.9.93.r1662.fc378b6
+pkgver=1.9.93.r1697.6484236c
pkgrel=1
pkgdesc='A Sony PlayStation emulator based on the PCSX-df Project'
arch=('i686' 'x86_64')
url='http://pcsxr.codeplex.com/'
license=('GPL')
-depends=('gtk3' 'libarchive' 'libcdio' 'libxv' 'sdl2')
-makedepends=('git' 'intltool' 'mesa')
+depends=('gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'libgl' 'libpulse' 'libx11'
+ 'libxext' 'libxtst' 'libxv' 'libxxf86vm' 'sdl2' 'zlib'
+ 'libarchive.so' 'libavcodec.so' 'libavformat.so' 'libavutil.so'
+ 'libm.so' 'libswresample.so')
+makedepends=('cmake' 'git' 'intltool' 'mesa')
[[ $CARCH == i686 ]] && makedepends+=('nasm')
provides=('pcsxr')
conflicts=('pcsxr' 'pcsx-df')
@@ -23,18 +26,31 @@ pkgver() {
echo "1.9.93.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
-build() {
+prepare() {
cd pcsxr/pcsxr
- chmod +x autogen.sh
- ./autogen.sh \
- --prefix='/usr' \
- --enable-{libcdio,opengl}
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd pcsxr/pcsxr/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
+ -DSND_BACKEND='pulse' \
+ -DENABLE_CCDDA='ON' \
+ -DUSE_LIBARCHIVE='ON' \
+ -DUSE_LIBCDIO='ON'
make
}
package() {
- cd pcsxr/pcsxr
+ cd pcsxr/pcsxr/build
make DESTDIR="${pkgdir}" install
}