summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2015-10-04 02:49:19 +0100
committerWorMzy Tykashi2015-10-04 02:49:19 +0100
commit55a4218bf32836d89914130b9da3dcaaecbd13ac (patch)
tree6d0862e1340665abd15ef0eaa76232b196bcd3a4
downloadaur-55a4218bf32836d89914130b9da3dcaaecbd13ac.tar.gz
Initial upload to AUR4
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD34
-rw-r--r--link_order.patch12
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee0e465b09a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = pcsxr-gtk2
+ pkgdesc = A Sony PlayStation (PSX) emulator based on the PCSX-df project (Gtk2 version)
+ pkgver = 1.9.92
+ pkgrel = 1
+ url = http://pcsxr.codeplex.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = mesa
+ depends = libcdio
+ depends = libgl
+ depends = libglade
+ depends = libxtst
+ depends = libxv
+ depends = sdl
+ conflicts = pcsxr
+ source = https://sources.archlinux.org/other/community/pcsxr/pcsxr-1.9.92.tar.bz2
+ source = link_order.patch
+ md5sums = 28411aed0b4424f97227d94bdefaec83
+ md5sums = ce021bfc4c19e553a2cdb95b7ca1eb01
+ makedepends_i686 = nasm
+
+pkgname = pcsxr-gtk2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d97b697ea538
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
+# Contributer: Fincer <fincer89@hotmail.com>
+
+pkgname=pcsxr-gtk2
+_pkgname=pcsxr
+pkgver=1.9.92
+pkgrel=1
+pkgdesc='A Sony PlayStation (PSX) emulator based on the PCSX-df project (Gtk2 version)'
+arch=('i686' 'x86_64')
+url='http://pcsxr.codeplex.com/'
+license=('GPL')
+conflicts=('pcsxr')
+depends=('libcdio' 'libgl' 'libglade' 'libxtst' 'libxv' 'sdl')
+makedepends=('mesa')
+makedepends_i686+=('nasm')
+
+# Accessible through /srv/ftp/other/community on nymeria.
+source=("https://sources.archlinux.org/other/community/pcsxr/pcsxr-${pkgver}.tar.bz2"
+"link_order.patch")
+
+md5sums=('28411aed0b4424f97227d94bdefaec83'
+ 'ce021bfc4c19e553a2cdb95b7ca1eb01')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ patch -Np1 -i "$srcdir/link_order.patch"
+ ./configure --prefix=/usr --enable-libcdio --enable-opengl
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/link_order.patch b/link_order.patch
new file mode 100644
index 000000000000..dbf4fc91a808
--- /dev/null
+++ b/link_order.patch
@@ -0,0 +1,12 @@
+--- a/gui/Makefile.in
++++ b/gui/Makefile.in
+@@ -244,8 +244,7 @@
+ AboutDlg.c
+
+ pcsx_LDADD = \
+- $(GTK2_LIBS) $(GLADE2_LIBS) -lpthread -lz -lm -lXext -lXtst \
+- ../libpcsxcore/libpcsxcore.a
++ ../libpcsxcore/libpcsxcore.a $(GTK2_LIBS) $(GLADE2_LIBS) -lpthread -lz -lm -lXext -lXtst
+
+ all: all-am
+