summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2019-10-22 00:41:41 +0300
committerStelios Tsampas2019-10-22 00:41:41 +0300
commitd683047afad2ca15e4edbddf0027830104d469c5 (patch)
tree0630b59fc7da5f48d3f0ea13f6ff92f03626e5ae
parent33da57f5cd08a5bf436d9e805f05cae7b1bc6008 (diff)
downloadaur-d683047afad2ca15e4edbddf0027830104d469c5.tar.gz
Add patch for newer pango versions
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--fix-pango.patch24
3 files changed, 36 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f908189f3c01..48a9d072f452 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pcsxr-pgxp-git
pkgdesc = A Sony PlayStation (PSX) emulator based on the PCSX-df Project with Parallel/Precision Geometry Transform Pipeline
- pkgver = 1.9.94.r1714.6f760410
- pkgrel = 2
+ pkgver = 1.9.94.r1731.62467b86
+ pkgrel = 1
url = http://ngemu.com/threads/pcsxr-pgxp.186369/
arch = x86_64
license = GPL
@@ -19,7 +19,9 @@ pkgbase = pcsxr-pgxp-git
conflicts = pcsxr
conflicts = pcsxr-pgxp
source = pcsxr-pgxp::git+https://github.com/iCatButler/pcsxr.git
- md5sums = SKIP
+ source = fix-pango.patch
+ sha256sums = SKIP
+ sha256sums = 40298efe5f3137fa6926a1315d2299ef1b311ec365674d63578235bb00f2e454
pkgname = pcsxr-pgxp-git
diff --git a/PKGBUILD b/PKGBUILD
index 9bb63e2e9e6a..28a16c062d7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Stelios Tsampas <loathingkernel @at gmail .dot com>
pkgname=pcsxr-pgxp-git
-pkgver=1.9.94.r1714.6f760410
-pkgrel=2
+pkgver=1.9.94.r1731.62467b86
+pkgrel=1
pkgdesc='A Sony PlayStation (PSX) emulator based on the PCSX-df Project with Parallel/Precision Geometry Transform Pipeline'
arch=('x86_64')
url='http://ngemu.com/threads/pcsxr-pgxp.186369/'
@@ -11,8 +11,10 @@ depends=('ffmpeg' 'gtk3' 'libarchive' 'libcdio' 'libxv')
makedepends=('cmake' 'git' 'intltool' 'mesa')
provides=('pcsxr' "${pkgname/%-git/}")
conflicts=('pcsxr' "${pkgname/%-git/}")
-source=("${pkgname/%-git/}::git+https://github.com/iCatButler/pcsxr.git")
-md5sums=('SKIP')
+source=("${pkgname/%-git/}::git+https://github.com/iCatButler/pcsxr.git"
+ 'fix-pango.patch')
+sha256sums=('SKIP'
+ '40298efe5f3137fa6926a1315d2299ef1b311ec365674d63578235bb00f2e454')
pkgver() {
cd "${pkgname/%-git/}"
@@ -25,6 +27,7 @@ prepare() {
rm -rf build
fi
mkdir build
+ patch -p1 -i "$srcdir"/fix-pango.patch
}
build() {
diff --git a/fix-pango.patch b/fix-pango.patch
new file mode 100644
index 000000000000..fdcf1560427a
--- /dev/null
+++ b/fix-pango.patch
@@ -0,0 +1,24 @@
+diff --git a/cmake/FindGTK3.cmake b/cmake/FindGTK3.cmake
+index 049a276f..9e75806c 100644
+--- a/cmake/FindGTK3.cmake
++++ b/cmake/FindGTK3.cmake
+@@ -50,6 +50,7 @@ if(GTK3_LIBRARY)
+ set_property(TARGET ${GTK3} PROPERTY INTERFACE_COMPILE_OPTIONS "${GTK3_PKG_CFLAGS_OTHER}")
+
+ set(GTK3_INCLUDE_DIRS)
++ include_directories(/usr/include/harfbuzz)
+
+ find_path(GTK3_INCLUDE_DIR "gtk/gtk.h"
+ HINTS ${GTK3_PKG_INCLUDE_DIRS})
+diff --git a/plugins/peopsxgl/CMakeLists.txt b/plugins/peopsxgl/CMakeLists.txt
+index 907009ce..850da301 100644
+--- a/plugins/peopsxgl/CMakeLists.txt
++++ b/plugins/peopsxgl/CMakeLists.txt
+@@ -18,6 +18,7 @@ set(GTK_LIBRARIES ${GTK3_LIBRARY} ${GDK3_LIBRARY} ${GDKPixbuf_LIBRARY} ${Pango_L
+
+ find_package(X11 REQUIRED)
+
++set(OpenGL_GL_PREFERENCE GLVND)
+ find_package(OpenGL REQUIRED)
+ if(NOT OPENGL_FOUND)
+ message(FATAL_ERROR "GL library not found")