summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2016-04-26 15:52:45 +0200
committerAlbert Graef2016-04-26 15:52:45 +0200
commite428a677394f706fe4feadaa08669f563e0ac238 (patch)
tree2b39ce76dc1cbc8a202c441ac16c82001cbb6aca
parent1212088e982e9b7c795379987176e03fe1ce6a41 (diff)
downloadaur-e428a677394f706fe4feadaa08669f563e0ac238.tar.gz
Bugfixes, add missing build dependencies.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--menu_openfile.patch34
3 files changed, 51 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0071f9158629..f563c4ddbf58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
# Generated by mksrcinfo v8
-# Thu Feb 11 05:37:06 UTC 2016
+# Tue Apr 26 13:50:58 UTC 2016
pkgbase = pd-l2ork
pkgdesc = L2Ork (Linux Laptop Orchestra) version of PureData
- pkgver = 1642.e3e30ff
+ pkgver = 1644.ec3b96b
pkgrel = 1
url = http://l2ork.music.vt.edu/main/?page_id=56
install = pd-l2ork.install
arch = i686
arch = x86_64
license = BSD
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = libtool
makedepends = git
makedepends = subversion
makedepends = swig
@@ -53,7 +56,9 @@ pkgbase = pd-l2ork
conflicts = pd-l2ork
options = !makeflags
source = pd-l2ork::git+https://github.com/pd-l2ork/pd.git
+ source = menu_openfile.patch
md5sums = SKIP
+ md5sums = 6eb362b0165fc9fc4409e3db5d2278c2
pkgname = pd-l2ork
diff --git a/PKGBUILD b/PKGBUILD
index 17307c5f115b..71b84aed9cb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# under /usr/include/pd-l2ork.
pkgname=pd-l2ork
-pkgver=1642.e3e30ff
+pkgver=1644.ec3b96b
pkgrel=1
pkgdesc="L2Ork (Linux Laptop Orchestra) version of PureData"
url="http://l2ork.music.vt.edu/main/?page_id=56"
@@ -19,18 +19,24 @@ depends=('bluez-libs' 'desktop-file-utils' 'dssi' 'fftw'
'libdc1394' 'libdv' 'libgl' 'libiec61883' 'libjpeg' 'libquicktime'
'libraw1394' 'libsndobj-cvs' 'libv4l' 'libvorbis' 'lua51' 'portaudio'
'smpeg' 'speex' 'stk' 'tk' 'tkpng' 'vlc' 'xapian-tcl-bindings')
-makedepends=('git' 'subversion' 'swig' 'curl' 'rsync')
+makedepends=('autoconf' 'automake' 'libtool' 'git' 'subversion' 'swig' 'curl' 'rsync')
conflicts=('pd-l2ork')
install=pd-l2ork.install
options=('!makeflags')
-source=("$pkgname::git+https://github.com/pd-l2ork/pd.git")
-md5sums=(SKIP)
+source=("$pkgname::git+https://github.com/pd-l2ork/pd.git"
+ "menu_openfile.patch")
+md5sums=('SKIP' '6eb362b0165fc9fc4409e3db5d2278c2')
pkgver() {
cd $srcdir/$pkgname
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
+prepare() {
+ cd $srcdir/$pkgname
+ patch -p1 < ../menu_openfile.patch
+}
+
build() {
unset CFLAGS
unset LDFLAGS
diff --git a/menu_openfile.patch b/menu_openfile.patch
new file mode 100644
index 000000000000..4dcc8e8793a8
--- /dev/null
+++ b/menu_openfile.patch
@@ -0,0 +1,34 @@
+diff --git a/pd/src/pd_menus_SHORT.tcl b/pd/src/pd_menus_SHORT.tcl
+index 929e985..5a7a8f1 100644
+--- a/pd/src/pd_menus_SHORT.tcl
++++ b/pd/src/pd_menus_SHORT.tcl
+@@ -90,4 +90,27 @@ proc ::pd_menus::update_recentfiles_on_menu {mymenu {write}} {
+ }
+ # write to config file
+ if {$write == true} { ::pd_guiprefs::write_recentfiles }
+-}
+\ No newline at end of file
++}
++
++# for compatibility with vanilla (menu_openfile command)
++namespace eval ::pd_menucommands:: {
++ namespace export menu_*
++}
++
++# open HTML docs from the menu using the OS-default HTML viewer
++proc ::pd_menucommands::menu_openfile {filename} {
++ if {$::tcl_platform(os) eq "Darwin"} {
++ exec sh -c [format "open '%s'" $filename]
++ } elseif {$::tcl_platform(platform) eq "windows"} {
++ exec rundll32 url.dll,FileProtocolHandler [format "%s" $filename] &
++ } else {
++ foreach candidate { gnome-open xdg-open sensible-browser iceweasel firefox \
++ mozilla galeon konqueror netscape lynx } {
++ set browser [lindex [auto_execok $candidate] 0]
++ if {[string length $browser] != 0} {
++ exec -- sh -c [format "%s '%s'" $browser $filename] &
++ break
++ }
++ }
++ }
++}