summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2015-06-13 22:58:10 +0200
committerAlbert Graef2015-06-13 22:58:10 +0200
commit202bf65e9fc0623a274ee2d68adbb93fcf957841 (patch)
treee80e079bf318a240ad876d05b7fa5164dfc5096f
downloadaur-202bf65e9fc0623a274ee2d68adbb93fcf957841.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
3 files changed, 60 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..da3773dbc1b3
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = pd-lv2plugin-git
+ pkgdesc = LV2 plugin host for Pd
+ pkgver = 14.539522c
+ pkgrel = 1
+ url = https://bitbucket.org/agraef/pd-lv2plugin/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = pd
+ depends = pd-pure
+ depends = pure-lilv
+ source = git+https://bitbucket.org/agraef/pd-lv2plugin
+ md5sums = SKIP
+
+pkgname = pd-lv2plugin-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da3773dbc1b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pd-lv2plugin-git
+ pkgdesc = LV2 plugin host for Pd
+ pkgver = 14.539522c
+ pkgrel = 1
+ url = https://bitbucket.org/agraef/pd-lv2plugin/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = pd
+ depends = pd-pure
+ depends = pure-lilv
+ source = git+https://bitbucket.org/agraef/pd-lv2plugin
+ md5sums = SKIP
+
+pkgname = pd-lv2plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f46cc89efa8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Albert Graef <aggraef at gmail dot com>
+
+pkgname=pd-lv2plugin-git
+pkgver=14.539522c
+pkgrel=1
+pkgdesc="LV2 plugin host for Pd"
+arch=("i686" "x86_64")
+license=('BSD')
+url="https://bitbucket.org/agraef/pd-lv2plugin/"
+depends=('pd' 'pd-pure' 'pure-lilv')
+makedepends=()
+source=("git+https://bitbucket.org/agraef/pd-lv2plugin")
+md5sums=(SKIP)
+
+pkgver() {
+ cd $srcdir/pd-lv2plugin
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd $srcdir/pd-lv2plugin
+ make || return 1
+}
+
+package() {
+ cd $srcdir/pd-lv2plugin
+ make DESTDIR=$pkgdir install || return 1
+}