summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrobot Viktor2018-12-05 19:27:27 +0300
committerDrobot Viktor2018-12-05 19:27:27 +0300
commitf023b0121f969cb41f049a939b1ad58ba9707e3b (patch)
tree0b54f820c1d21a66dd03f36e966b7d43a50274cb
downloadaur-f023b0121f969cb41f049a939b1ad58ba9707e3b.tar.gz
First release
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD35
-rw-r--r--pdb2pqr.patch74
3 files changed, 132 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..904b95d39749
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = pdb2pqr
+ pkgdesc = Electrostatic and solvation properties for complex molecules
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = http://www.poissonboltzmann.org/
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = pyinstaller2
+ makedepends = git
+ makedepends = gcc
+ depends = swig
+ depends = python2
+ depends = python2-networkx
+ depends = python2-numpy
+ depends = apbs
+ source = git+https://github.com/Electrostatics/apbs-pdb2pqr.git#commit=044f531f8fb944f7b14c9f34ff33833357b0fea4
+ source = pdb2pqr.patch
+ md5sums = SKIP
+ md5sums = 19cb8e794d49e4d2bc04df54a895f3ad
+
+pkgname = pdb2pqr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d923286f849
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+pkgname=pdb2pqr
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="Electrostatic and solvation properties for complex molecules"
+arch=(x86_64 i686)
+url="http://www.poissonboltzmann.org/"
+license=('MIT')
+depends=('swig' 'python2' 'python2-networkx' 'python2-numpy' 'apbs')
+makedepends=('pyinstaller2' 'git' 'gcc')
+source=("git+https://github.com/Electrostatics/apbs-pdb2pqr.git#commit=044f531f8fb944f7b14c9f34ff33833357b0fea4"
+ "pdb2pqr.patch")
+md5sums=('SKIP'
+ '19cb8e794d49e4d2bc04df54a895f3ad')
+
+prepare() {
+ cd ${srcdir}/apbs-pdb2pqr/pdb2pqr
+
+ patch -Np0 -i "${srcdir}/pdb2pqr.patch"
+}
+
+build() {
+ cd ${srcdir}/apbs-pdb2pqr/pdb2pqr
+
+ python2 scons/scons.py
+}
+
+package() {
+ cd ${srcdir}/apbs-pdb2pqr/pdb2pqr
+
+ pyinstaller2 pdb2pqr.spec
+
+ mkdir -p ${pkgdir}/opt
+ cp -ar dist/pdb2pqr ${pkgdir}/opt/pdb2pqr
+}
diff --git a/pdb2pqr.patch b/pdb2pqr.patch
new file mode 100644
index 000000000000..977c0f285e22
--- /dev/null
+++ b/pdb2pqr.patch
@@ -0,0 +1,74 @@
+--- build_config.py 2018-12-05 19:05:52.848580011 +0300
++++ build_config.py 2018-12-05 19:04:58.499308161 +0300
+@@ -9,7 +9,7 @@
+ #Sets the install location of pdb2pqr.
+ #This defaults to ~/pdb2pqr
+
+-#PREFIX="~/pdb2pqr"
++PREFIX="/opt/pdb2pqr"
+
+
+ #Website URL
+@@ -17,28 +17,28 @@
+ #This defaults to http://<COMPUTER NAME>/pdb2pqr/
+ # where <COMPUTER NAME> is the network name of the computer.
+
+-#URL="http://<COMPUTER NAME>/pdb2pqr/"
++URL="http://nbcr-222.ucsd.edu/pdb2pqr_2.1.1/"
+
+
+ #APBS binary
+ #Change this to specify the location of the APBS binary if installed.
+ #This is used for the web interface to pdb2pqr. Provide an absolute path. Relative paths and ~ usually will not work correctly.
+
+-#APBS=""
++APBS="/usr/bin/apbs"
+
+
+ #OPAL service URL
+ #Set this value to use an opal service for processing
+ # pdb2pqr jobs for the web front end.
+
+-#OPAL="http://nbcr-222.ucsd.edu/opal2/services/pdb2pqr_1.8"
++OPAL="http://nbcr-222.ucsd.edu/opal2/services/pdb2pqr_2.1.1"
+
+
+ #APBS_OPAL service URL
+ #Set this value to use an opal service for processing
+ # apbs jobs for the web front end.
+
+-#APBS_OPAL="http://nbcr-222.ucsd.edu/opal2/services/apbs_1.3"
++APBS_OPAL="http://nbcr-222.ucsd.edu/opal2/services/apbs_1.4.2.1"
+
+
+ #MAX_ATOMS
+@@ -52,19 +52,19 @@
+ #Set to False to skip building ligand and pdb2pka support. Requires numpy.
+ # Defaults to True
+
+-#BUILD_PDB2PKA=False
++BUILD_PDB2PKA=True
+
+ #DEBUG
+ #Set to True to build compiled extentions with debug headers.
+ #Defaults to False
+
+-#DEBUG=True
++DEBUG=False
+
+ #CXXFLAGS
+ #Set to add extra CXX flags to the build.
+ #Defaults to ""
+
+-#EXTRA_CXXFLAGS="-fPIC"
++EXTRA_CXXFLAGS="-fPIC"
+
+ #EXTRA_LINKFLAGS
+ #Set to add extra CXX flags to the build.
+@@ -78,4 +78,4 @@
+ # Requires swig on the the user path.
+ # Defaults to False
+
+-#REBUILD_SWIG=True
+\ В конце файла нет новой строки
++REBUILD_SWIG=True