summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrobot Viktor2018-12-07 17:39:33 +0300
committerDrobot Viktor2018-12-07 17:39:33 +0300
commitfae3347ae4323624172a23d07019294b98815894 (patch)
tree6be923638927236eb6d3426655a5b13b199d1f81
parentf023b0121f969cb41f049a939b1ad58ba9707e3b (diff)
downloadaur-fae3347ae4323624172a23d07019294b98815894.tar.gz
Fixed PyInstaller issue
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 904b95d39749..9243d8daae19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = pdb2pqr
pkgdesc = Electrostatic and solvation properties for complex molecules
pkgver = 2.1.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.poissonboltzmann.org/
arch = x86_64
arch = i686
license = MIT
- makedepends = pyinstaller2
makedepends = git
makedepends = gcc
depends = swig
diff --git a/PKGBUILD b/PKGBUILD
index 8d923286f849..dffe8bce4a14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
pkgname=pdb2pqr
pkgver=2.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Electrostatic and solvation properties for complex molecules"
arch=(x86_64 i686)
url="http://www.poissonboltzmann.org/"
license=('MIT')
depends=('swig' 'python2' 'python2-networkx' 'python2-numpy' 'apbs')
-makedepends=('pyinstaller2' 'git' 'gcc')
+makedepends=('git' 'gcc')
source=("git+https://github.com/Electrostatics/apbs-pdb2pqr.git#commit=044f531f8fb944f7b14c9f34ff33833357b0fea4"
"pdb2pqr.patch")
md5sums=('SKIP'
@@ -28,8 +28,7 @@ build() {
package() {
cd ${srcdir}/apbs-pdb2pqr/pdb2pqr
- pyinstaller2 pdb2pqr.spec
+ mkdir -p ${pkgdir}/opt/pdb2pqr
- mkdir -p ${pkgdir}/opt
- cp -ar dist/pdb2pqr ${pkgdir}/opt/pdb2pqr
+ python2 scons/scons.py PREFIX=${pkgdir}/opt/pdb2pqr install
}