summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Auditor2015-07-16 18:37:46 +0200
committerStefan Auditor2015-07-16 18:37:46 +0200
commit4c71d6f720b0b244ea0b5aa42c99d9dd9a2c733b (patch)
treeebfac93c5e422547c6863783837e2341e8b46404
parent663eb0e3f7df66132dc65dc9044ce413fef8682e (diff)
downloadaur-4c71d6f720b0b244ea0b5aa42c99d9dd9a2c733b.tar.gz
Add post_install and post_upgrade hooks
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--pdepend.install8
3 files changed, 14 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa101a73fa34..154ab8c26c03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,9 @@ pkgbase = pdepend
license = BSD
depends = php
source = http://static.pdepend.org/php/2.1.0/pdepend.phar
+ source = pdepend.install
md5sums = a865a41bc90c8ad121f6055e633f9442
+ md5sums = 2ac82322f6c7bf452459d422ce1f8bc3
pkgname = pdepend
diff --git a/PKGBUILD b/PKGBUILD
index 1e226d1fad32..dd83c926c64e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,10 @@ url="http://pdepend.org/"
arch=('any')
license=('BSD')
depends=('php')
-source=("http://static.pdepend.org/php/${pkgver}/pdepend.phar")
-md5sums=('a865a41bc90c8ad121f6055e633f9442')
+source=("http://static.pdepend.org/php/${pkgver}/pdepend.phar"
+ "pdepend.install")
+md5sums=('a865a41bc90c8ad121f6055e633f9442'
+ '2ac82322f6c7bf452459d422ce1f8bc3')
package() {
install -D -m 755 "${srcdir}/pdepend.phar" "${pkgdir}/usr/share/webapps/bin/pdepend.phar"
diff --git a/pdepend.install b/pdepend.install
new file mode 100644
index 000000000000..57ecc8325034
--- /dev/null
+++ b/pdepend.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo
+ echo "Warning: bz2.so must be enabled in your php.ini"
+}
+
+post_upgrade() {
+ post_install
+}