summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Auditor2015-07-16 17:33:56 +0200
committerStefan Auditor2015-07-16 17:33:56 +0200
commitd5a65cf6459236951325d00f46a6bd6b0e9ce858 (patch)
treed787fb7e4710df48ef0122278f36204b7679f601
parentd6923339b3f02daed324e35807dc821e15fbaa97 (diff)
downloadaur-d5a65cf6459236951325d00f46a6bd6b0e9ce858.tar.gz
Add perms parameter to auth request
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--pdepend.install8
3 files changed, 14 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cc65dbf293b..66251bb93bce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,9 @@ pkgbase = pdepend
license = GPLv3
depends = php
source = http://static.pdepend.org/php/2.1.0/pdepend.phar
+ source = pdepend.install
md5sums = a865a41bc90c8ad121f6055e633f9442
+ md5sums = 301f5f1b4a50992db3d93f1b5178bad5
pkgname = pdepend
diff --git a/PKGBUILD b/PKGBUILD
index 3de2eec56a88..e5625f46a793 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,10 @@ url="http://pdepend.org/"
arch=('any')
license=('GPLv3')
depends=('php')
-source=("http://static.pdepend.org/php/${pkgver}/pdepend.phar")
-md5sums=('a865a41bc90c8ad121f6055e633f9442')
+source=("http://static.pdepend.org/php/${pkgver}/pdepend.phar"
+ "pdepend.install")
+md5sums=('a865a41bc90c8ad121f6055e633f9442'
+ '301f5f1b4a50992db3d93f1b5178bad5')
package() {
install -D -m 755 "${srcdir}/pdepend.phar" "${pkgdir}/usr/share/webapps/bin/pdepend.phar"
diff --git a/pdepend.install b/pdepend.install
new file mode 100644
index 000000000000..57ecc8325034
--- /dev/null
+++ b/pdepend.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo
+ echo "Warning: bz2.so must be enabled in your php.ini"
+}
+
+post_upgrade() {
+ post_install
+}