summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2015-06-13 22:58:13 +0200
committerAlbert Graef2015-06-13 22:58:13 +0200
commit6234e888d52ce350d9454a69a336ac0675b0fc60 (patch)
treeb580af29590b458b8ed6d4e4477e93b06cb31b2e
downloadaur-6234e888d52ce350d9454a69a336ac0675b0fc60.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
3 files changed, 60 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..42fdf7a40b99
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = pdextended-lv2plugin-git
+ pkgdesc = LV2 plugin host for Pd, Pd-Extended version
+ pkgver = 14.539522c
+ pkgrel = 1
+ url = https://bitbucket.org/agraef/pd-lv2plugin/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = pd-extended
+ depends = pdextended-pure
+ depends = pure-lilv
+ source = git+https://bitbucket.org/agraef/pd-lv2plugin
+ md5sums = SKIP
+
+pkgname = pdextended-lv2plugin-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42fdf7a40b99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pdextended-lv2plugin-git
+ pkgdesc = LV2 plugin host for Pd, Pd-Extended version
+ pkgver = 14.539522c
+ pkgrel = 1
+ url = https://bitbucket.org/agraef/pd-lv2plugin/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = pd-extended
+ depends = pdextended-pure
+ depends = pure-lilv
+ source = git+https://bitbucket.org/agraef/pd-lv2plugin
+ md5sums = SKIP
+
+pkgname = pdextended-lv2plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb579041863d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Albert Graef <aggraef at gmail dot com>
+
+pkgname=pdextended-lv2plugin-git
+pkgver=14.539522c
+pkgrel=1
+pkgdesc="LV2 plugin host for Pd, Pd-Extended version"
+arch=("i686" "x86_64")
+license=('BSD')
+url="https://bitbucket.org/agraef/pd-lv2plugin/"
+depends=('pd-extended' 'pdextended-pure' 'pure-lilv')
+makedepends=()
+source=("git+https://bitbucket.org/agraef/pd-lv2plugin")
+md5sums=(SKIP)
+
+pkgver() {
+ cd $srcdir/pd-lv2plugin
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd $srcdir/pd-lv2plugin
+ make PD=pd-extended || return 1
+}
+
+package() {
+ cd $srcdir/pd-lv2plugin
+ make DESTDIR=$pkgdir PD=pd-extended install || return 1
+}