summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFaerbit2016-03-23 18:33:50 +0100
committerFaerbit2016-03-23 18:33:50 +0100
commit3e52190a20843e4316447b48bcc86ca782e1e1cc (patch)
treef0a08a5d2cb1021584c9814cea39632e80464f75
downloadaur-3e52190a20843e4316447b48bcc86ca782e1e1cc.tar.gz
Initial pkg creation.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD38
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26081f4d9337
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Mar 23 17:33:38 UTC 2016
+pkgbase = pdf-aas-git
+ pkgdesc = Little webservice which converts office documents to PDF files.
+ pkgver = 4.a2f5460
+ pkgrel = 1
+ url = https://github.org/faerbit/pdf-aas
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = MIT
+ makedepends = git
+ source = git+https://github.com/faerbit/pdf-aas.git
+ md5sums = SKIP
+
+pkgname = pdf-aas-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..09eb9ee61c57
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!campus-ics-feed-git.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dcf0d5f44c14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer : Faerbit <faerbit at gmail dot com>
+
+pkgname=pdf-aas-git
+_pkgname=${pkgname%-git}
+pkgver=4.a2f5460
+pkgrel=1
+pkgdesc="Little webservice which converts office documents to PDF files."
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.org/faerbit/pdf-aas"
+license=('MIT')
+dependencies=('python3' 'python-flask')
+makedepends=('git')
+source=("git+https://github.com/faerbit/pdf-aas.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ # License
+ install -D -m644 LICENSE.md "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ # Webapp
+ install -D -m644 server.py "$pkgdir/usr/share/webapps/${_pkgname}/server.py"
+
+ install -d -m644 "$pkgdir/usr/share/webapps/${_pkgname}/templates"
+ for file in $(find templates -type f ); do
+ install -D -m644 "${file}" "$pkgdir/usr/share/webapps/${_pkgname}/templates"
+ done
+ install -d -m644 "$pkgdir/usr/share/webapps/${_pkgname}/static"
+ for file in $(find static -type f ); do
+ install -D -m644 "${file}" "$pkgdir/usr/share/webapps/${_pkgname}/static"
+ done
+
+ chown -R root:http "$pkgdir/usr/share/webapps/${_pkgname}"
+}