summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuval Adam2015-06-30 15:51:45 +0300
committerYuval Adam2015-06-30 15:51:45 +0300
commit38b6fef12a03889e69c22ed8055d7001d4ed0efe (patch)
tree09c328e4c861bfa25e0a1fac0bfe0cc43a005d08
downloadaur-38b6fef12a03889e69c22ed8055d7001d4ed0efe.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d56ed90996c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pdf-redact-tools
+ pkgdesc = Securely redact and strip metadata from docs before publishing
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/firstlook/pdf-redact-tools
+ arch = any
+ license = GPLv3
+ depends = python2
+ depends = imagemagick
+ depends = perl-image-exiftool
+ source = https://github.com/firstlook/pdf-redact-tools/archive/v0.1.tar.gz
+ sha256sums = 9d5f095e5d056eb527c08c4736b45c99aa6399424dd6ed7155e3d7cd1600c55e
+
+pkgname = pdf-redact-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdfc4fab7e5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Yuval Adam <yuval at y3xz dot com> PGP-Key: 271386AA2EB7672F
+
+pkgname=pdf-redact-tools
+pkgver=0.1
+pkgrel=1
+pkgdesc="Securely redact and strip metadata from docs before publishing"
+arch=('any')
+url="https://github.com/firstlook/pdf-redact-tools"
+license=(GPLv3)
+depends=('python2' 'imagemagick' 'perl-image-exiftool')
+source=("https://github.com/firstlook/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('9d5f095e5d056eb527c08c4736b45c99aa6399424dd6ed7155e3d7cd1600c55e')
+
+package() {
+ cd $srcdir/${pkgname}-${pkgver}
+ sed -i '1 s/python/python2/g' pdf-redact-tools
+ install -Dm755 pdf-redact-tools "${pkgdir}/usr/bin/pdf-redact-tools"
+}
+# vim:set ts=2 sw=2 et: