summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoe2018-06-19 11:20:22 +0200
committerzoe2018-06-19 11:20:22 +0200
commit51aeeb6a4da7b07e8d8210a3991b518de27efa4d (patch)
treee9862bb7f226cc32fead458f6ad27c6a22aa217d
parente3544e0859e2f901ab4326603246102a75da829b (diff)
downloadaur-51aeeb6a4da7b07e8d8210a3991b518de27efa4d.tar.gz
Cosmetic changes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rwxr-xr-xpdf-remove-blank-pages.sh7
3 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54cd00f1d3c3..6ca4aeec73c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Jun 19 09:09:41 UTC 2018
+# Tue Jun 19 09:19:59 UTC 2018
pkgbase = pdf-remove-blank-pages
pkgdesc = Automatically remove blank pages from pdf. For text-pdf only, not for images-pdf (removes pages with no text in it)
pkgver = 0.2
- pkgrel = 1
+ pkgrel = 2
url = https://repolinux.wordpress.com/2012/04/05/automatically-remove-blank-pages-from-pdf/
arch = any
license = GPLv3+
@@ -15,7 +15,7 @@ pkgbase = pdf-remove-blank-pages
source = non-blank-page-ranges.py
source = pdf-remove-blank-pages.sh
md5sums = 1a9c76689a828c18b1263ef11c3ee990
- md5sums = e368efb443e71690e7319ed05bef21d9
+ md5sums = 0e4c76df31ae13d6b3f3b2aca3556ed8
pkgname = pdf-remove-blank-pages
diff --git a/PKGBUILD b/PKGBUILD
index a2eede25660a..e60a07218cab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=pdf-remove-blank-pages
pkgver=0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Automatically remove blank pages from pdf. For text-pdf only, not for images-pdf (removes pages with no text in it)"
arch=(any)
url="https://repolinux.wordpress.com/2012/04/05/automatically-remove-blank-pages-from-pdf/"
license=("GPLv3+")
depends=('python' 'bash' 'pdftk' 'poppler' 'gawk')
source=("non-blank-page-ranges.py" "pdf-remove-blank-pages.sh")
-md5sums=('1a9c76689a828c18b1263ef11c3ee990' 'e368efb443e71690e7319ed05bef21d9')
+md5sums=('1a9c76689a828c18b1263ef11c3ee990' '0e4c76df31ae13d6b3f3b2aca3556ed8')
package() {
diff --git a/pdf-remove-blank-pages.sh b/pdf-remove-blank-pages.sh
index 5de0f84cd962..964a7d0dd8f7 100755
--- a/pdf-remove-blank-pages.sh
+++ b/pdf-remove-blank-pages.sh
@@ -1,6 +1,5 @@
#! /bin/bash
-echo $@
BEGIN=1
END=0
filename=""
@@ -29,12 +28,12 @@ if [ $filename == "" ]; then
exit 99
fi
-if [ $END == 0 ]; then
+if [ $END == 0 ]; then # apply default : last page of the pdf
END=$(pdfinfo $filename | grep Pages | awk '{print $2}')
fi
-echo "BEGIN="$BEGIN
-echo "END="$END
+echo "BEGIN="$BEGIN " first page"
+echo "END="$END " last page"
echo "filename="$filename
# get non-blank ranges