summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrançois Boulogne2015-08-09 14:50:20 -0400
committerFrançois Boulogne2015-08-09 14:50:20 -0400
commita9f5fc0825dc210f2e2ffeca359e7b684e1aa408 (patch)
tree3715e1fc3ab98cfb4bce82ac5dfa4318e025000d
downloadaur-a9f5fc0825dc210f2e2ffeca359e7b684e1aa408.tar.gz
first version
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00f96e965c29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pdf2htmlex
+ pkgdesc = Convert PDF to HTML without losing text or format
+ pkgver = 0.14.6
+ pkgrel = 1
+ url = http://coolwanglu.github.com/pdf2htmlEX/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ depends = poppler
+ depends = fontforge
+ optdepends = ttfautohint: Provides automated hinting process for web fonts
+ provides = pdf2htmlex
+ conflicts = pdf2htmlex
+ replaces = pdf2htmlex
+ source = https://github.com/coolwanglu/pdf2htmlEX/archive/v0.14.6.tar.gz
+ sha256sums = 320ac2e1c2ea4a2972970f52809d90073ee00a6c42ef6d9833fb48436222f0e5
+
+pkgname = pdf2htmlex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b56e31d81ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Francois Boulogne <fboulogne at april dot org>
+# Maintainer: Francois Boulogne <fboulogne at april dot org>
+
+pkgname=pdf2htmlex
+pkgver=0.14.6
+pkgrel=1
+pkgdesc="Convert PDF to HTML without losing text or format"
+arch=('i686' 'x86_64')
+url="http://coolwanglu.github.com/pdf2htmlEX/"
+license=('GPL3')
+depends=('poppler' 'fontforge')
+makedepends=('cmake' 'git')
+optdepends=('ttfautohint: Provides automated hinting process for web fonts')
+provides=('pdf2htmlex')
+conflicts=('pdf2htmlex')
+replaces=('pdf2htmlex')
+source=(https://github.com/coolwanglu/pdf2htmlEX/archive/v${pkgver}.tar.gz)
+sha256sums=('320ac2e1c2ea4a2972970f52809d90073ee00a6c42ef6d9833fb48436222f0e5')
+
+
+build() {
+ cd "$srcdir/pdf2htmlEX-${pkgver}"
+
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/pdf2htmlEX-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+
+# vim:ts=2:sw=2:et: