summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralexandruianu2015-06-25 15:55:07 +0300
committeralexandruianu2015-06-25 15:55:07 +0300
commit57d805fb6f6bf73fa1c1dbb9c5343debe493f79a (patch)
tree72a0e9f94d73643b4478c52ad7180c87e1ba238f
downloadaur-57d805fb6f6bf73fa1c1dbb9c5343debe493f79a.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e608e544fe45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pdf2img-c
+ pkgdesc = Easily convert PDF to multiple image formats with a single click. C version of pdf2img.
+ pkgver = 90.9b4c3e1
+ pkgrel = 1
+ url = https://github.com/wifiextender/pdf2png
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = pkg-config
+ makedepends = gcc
+ depends = gtk3
+ depends = glibc
+ depends = ghostscript
+ conflicts = pdf2img
+ conflicts = pdf2img-git
+ replaces = pdf2img
+ source = git+https://github.com/wifiextender/pdf2png.git
+ md5sums = SKIP
+
+pkgname = pdf2img-c
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f718a30a0f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Author: wifiextender <aaron_caffrey at hotmail dot com>
+# Maintainer: Alexandru Ianu <alexandru.ianu at gmail.com>
+
+pkgname=pdf2img-c
+pkgver=90.9b4c3e1
+pkgrel=1
+pkgdesc="Easily convert PDF to multiple image formats with a single click. C version of pdf2img."
+arch=('any')
+url="https://github.com/wifiextender/pdf2png"
+license=('GPL3')
+conflicts=('pdf2img' 'pdf2img-git')
+replaces=('pdf2img')
+depends=('gtk3' 'glibc' 'ghostscript')
+makedepends=('git' 'pkg-config' 'gcc')
+source=('git+https://github.com/wifiextender/pdf2png.git')
+md5sums=('SKIP')
+
+build() {
+ cd $srcdir/pdf2png/C-version/
+ make
+}
+
+package() {
+ cd $srcdir
+
+ # Start file
+ install -Dm755 pdf2png/C-version/pdf2img $pkgdir/usr/bin/pdf2img
+
+ # Desktop icon
+ install -Dm644 pdf2png/pygtk3/img/Pdf2img.desktop $pkgdir/usr/share/applications/pdf2img.desktop
+ install -Dm644 pdf2png/C-version/img/pdf2img_icon.png $pkgdir/usr/share/icons/pdf2img_icon.png
+}
+
+pkgver() {
+ cd $srcdir/pdf2png
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+} \ No newline at end of file