summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZachary Elliott2017-06-01 23:35:05 -0400
committerZachary Elliott2017-06-01 23:38:26 -0400
commit2f30c1916d410124600c8b2da5a5822dd1f6f54f (patch)
tree6e899ce78a4de309bf6a73a86395f7bb8f6f333d
downloadaur-2f30c1916d410124600c8b2da5a5822dd1f6f54f.tar.gz
Create pdf2laser package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e45751b49f1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pdf2laser
+ pkgdesc = CLI tool printing pdf files to an Epilog laser cutter over the network
+ pkgver = 0.4.0
+ pkgrel = 1
+ epoch = 0
+ url = https://github.com/zellio/pdf2laser
+ arch = x86_64
+ license = GPL3
+ depends = ghostscript
+ source = https://github.com/zellio/pdf2laser/archive/v0.4.0.tar.gz
+ sha512sums = 257e084e724ec2ad32a0541b1cc12403d54aca2a66c760670c8c345342115e59b2e68be5913a02f3253709de88172865ab5e499c53a12ded8f4c3cf0c013013d
+
+pkgname = pdf2laser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f318c5df052b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Zachary Elliott <contact@zell.io>
+
+pkgname=pdf2laser
+pkgver=0.4.0
+pkgrel=1
+epoch=0
+pkgdesc="CLI tool printing pdf files to an Epilog laser cutter over the network"
+arch=(x86_64)
+url="https://github.com/zellio/pdf2laser"
+license=('GPL3')
+depends=('ghostscript')
+makedepends=()
+source=("https://github.com/zellio/$pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('257e084e724ec2ad32a0541b1cc12403d54aca2a66c760670c8c345342115e59b2e68be5913a02f3253709de88172865ab5e499c53a12ded8f4c3cf0c013013d')
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ aclocal -I m4 --install
+ autoheader
+ libtoolize --force
+ automake --add-missing --foreign
+ autoconf
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ cd "$pkgdir"
+ mkdir -p usr/share/bash-completion/completions
+ mv usr/etc/bash_completion.d/pdf2laser usr/share/bash-completion/completions
+ rmdir usr/etc/bash_completion.d usr/etc
+}