summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaditya Bagga2015-06-09 08:49:08 +0530
committerAaditya Bagga2015-06-09 08:49:08 +0530
commit58773844efaa6560e4e1bcc04dc13ea7382d25ba (patch)
tree54f8912996df1f673e13076f370592cb3ea3014e
downloadaur-58773844efaa6560e4e1bcc04dc13ea7382d25ba.tar.gz
pdf2png: initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cea7c7235c0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pdf2png
+ pkgdesc = Convert PDF books to PNG, JPG, and other image formats.
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://github.com/aadityabagga/pdf2png
+ arch = any
+ license = GPL
+ depends = python-gobject
+ depends = ghostscript
+ conflicts = pdf2img-git
+ source = http://github.com/aadityabagga/pdf2png/archive/0.5.tar.gz
+ md5sums = f7cb3d67d5acb978e6ce910dfd213937
+
+pkgname = pdf2png
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78e5a1435e4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: aaditya <aaditya_gnulinux@zoho.com>
+
+pkgname=pdf2png
+pkgver=0.5
+pkgrel=1
+pkgdesc="Convert PDF books to PNG, JPG, and other image formats."
+url="https://github.com/aadityabagga/pdf2png"
+arch=('any')
+license=('GPL')
+depends=('python-gobject' 'ghostscript')
+makedepends=()
+conflicts=('pdf2img-git')
+source=("http://github.com/aadityabagga/pdf2png/archive/${pkgver}.tar.gz")
+md5sums=('f7cb3d67d5acb978e6ce910dfd213937')
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et: