summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Birks2017-10-24 01:30:07 -0400
committerDavid Birks2017-10-24 01:30:07 -0400
commitb47a0a1464420e18e85b61cab13c918d08ef03d5 (patch)
tree19fa38f5ef6c3a81e9a1982ece00151371201db4
parent74079e9c0f282c478ecddbf68c00e798e83fa84a (diff)
downloadaur-pdfedit-bin.tar.gz
Update to 0.4.5-2
Reworked the PKGBUILD as well.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 19 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed55bd595118..c2620c99f760 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Thu Mar 31 22:18:38 UTC 2016
pkgbase = pdfedit-bin
- pkgdesc = Full featured editor for manipulating PDF documents (built from Debian binaries)
+ pkgdesc = Editor for manipulating PDF documents
pkgver = 0.4.5
- pkgrel = 4
+ pkgrel = 1
url = http://pdfedit.petricek.net/
arch = i686
arch = x86_64
@@ -13,9 +11,10 @@ pkgbase = pdfedit-bin
depends = gsfonts
depends = zlib
provides = pdfedit
- conflicts = pdfedit
- source = http://old-releases.ubuntu.com/ubuntu/pool/universe/p/pdfedit/pdfedit_0.4.5-2_amd64.deb
- sha256sums = 3c64fa6e242a2e6b7df6996c55b2c663680878833093ce3142d622dec511c7ad
+ source_i686 = http://old-releases.ubuntu.com/ubuntu/pool/universe/p/pdfedit/pdfedit_0.4.5-2_i386.deb
+ sha256sums_i686 = 1fed814ad4516877d9a125ba6fc73a4771da0cc80601d59f3c6440ea97cf9ccd
+ source_x86_64 = http://old-releases.ubuntu.com/ubuntu/pool/universe/p/pdfedit/pdfedit_0.4.5-2_amd64.deb
+ sha256sums_x86_64 = 3c64fa6e242a2e6b7df6996c55b2c663680878833093ce3142d622dec511c7ad
pkgname = pdfedit-bin
diff --git a/PKGBUILD b/PKGBUILD
index 4857d7042914..5894939514ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,21 @@
-# Submitter: McNoggins < gagnon88 at gmail >
+# Maintainer: David Birks <david@tellus.space>
+# Contributor: McNoggins <gagnon88 at gmail>
+
pkgname=pdfedit-bin
pkgver=0.4.5
_debpkgrel=2
-pkgrel=4
-pkgdesc="Full featured editor for manipulating PDF documents (built from Debian binaries)"
+pkgrel=1
+pkgdesc="Editor for manipulating PDF documents"
url="http://pdfedit.petricek.net/"
-arch=('i686' 'x86_64')
-license=('GPL')
-depends=('qt3' 't1lib' 'gsfonts' 'zlib')
-provides=('pdfedit')
-conflicts=('pdfedit')
-
-if [[ $CARCH == i686 ]]; then
- _debarch=i386
- sha256sums=('1fed814ad4516877d9a125ba6fc73a4771da0cc80601d59f3c6440ea97cf9ccd')
-else
- _debarch=amd64
- sha256sums=('3c64fa6e242a2e6b7df6996c55b2c663680878833093ce3142d622dec511c7ad')
-fi
-
-source=(http://old-releases.ubuntu.com/ubuntu/pool/universe/p/pdfedit/pdfedit_${pkgver}-${_debpkgrel}_${_debarch}.deb)
+arch=("i686" "x86_64")
+license=("GPL")
+depends=("qt3" "t1lib" "gsfonts" "zlib")
+provides=("pdfedit")
+source_i686=("http://old-releases.ubuntu.com/ubuntu/pool/universe/p/pdfedit/pdfedit_${pkgver}-${_debpkgrel}_i386.deb")
+source_x86_64=("http://old-releases.ubuntu.com/ubuntu/pool/universe/p/pdfedit/pdfedit_${pkgver}-${_debpkgrel}_amd64.deb")
+sha256sums_x86_64=("3c64fa6e242a2e6b7df6996c55b2c663680878833093ce3142d622dec511c7ad")
+sha256sums_i686=("1fed814ad4516877d9a125ba6fc73a4771da0cc80601d59f3c6440ea97cf9ccd")
package() {
tar -xf data.tar.?z -C "$pkgdir" ./usr
}
-
-# vim:set ts=2 sw=2 ft=sh et: