summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVirgil Dupras2015-06-08 21:56:16 +0000
committerVirgil Dupras2015-06-08 21:56:55 +0000
commit17f5f06e1175c235f5a9c6755f69a88a5fa8d7e8 (patch)
tree5246f601e54241c77c9a46162cc052ab7243c6cc
downloadaur-17f5f06e1175c235f5a9c6755f69a88a5fa8d7e8.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD63
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04b7c3b1f004
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pdfmasher
+ pkgdesc = PDF to eBook Conversion Tool
+ pkgver = 0.7.4
+ pkgrel = 2
+ url = http://www.hardcoded.net/pdfmasher/
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python
+ depends = python-pyqt4
+ depends = python-cssutils
+ depends = python-lxml
+ depends = python-markdown
+ depends = python-cssselect
+
+pkgname = pdfmasher
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9ad544ce2378
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.xz
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04209bc24f88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Blake Dickie <gentro_silva@shaw.ca>
+pkgname=pdfmasher
+pkgver=0.7.4
+pkgrel=2
+pkgdesc="PDF to eBook Conversion Tool"
+arch=(any)
+url="http://www.hardcoded.net/pdfmasher/"
+license=('GPL')
+depends=('python' 'python-pyqt4' 'python-cssutils' 'python-lxml' 'python-markdown' 'python-cssselect')
+makedepends=('git')
+source=()
+md5sums=()
+
+
+build() {
+
+ cd "$srcdir"
+ msg "Connecting to Git server...."
+
+ if [[ -d "$pkgname" ]]; then
+ cd "$pkgname"
+ git pull
+ msg "The local files are updated."
+ else
+ git clone "https://github.com/hsoft/pdfmasher.git" "$pkgname"
+ cd "$pkgname"
+ fi
+
+ msg "Git checkout done or server timeout"
+
+ msg "Switching to Production Tag"
+ # NOTE: The "-arch" suffix is temporary. Recent fixes have been made upstream to make Arch
+ # packaging easier, but there wasn't a release with these changes yet, so I've made a special
+ # "arch" tag in the upstream repo. After the next release, we can remove that suffix.
+ git checkout "$pkgver"-arch
+
+ source bootstrap.sh
+ source env/bin/activate
+
+ msg "Starting build..."
+ python configure.py
+ python build.py --clean
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ mkdir -p "${pkgdir}/usr/share/applications"
+ cp debian/pdfmasher.desktop "${pkgdir}/usr/share/applications"
+
+ python package.py --arch-pkg
+ cd "build/pdfmasher-arch"
+
+ mkdir -p "$pkgdir/usr/share/pdfmasher"
+ cp -a * "$pkgdir/usr/share/pdfmasher/"
+ install -dm755 "${pkgdir}/usr/share/pdfmasher"
+ chmod a+x "$pkgdir/usr/share/pdfmasher/run.py"
+
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s ../share/pdfmasher/run.py "$pkgdir/usr/bin/pdfmasher"
+}
+
+# vim:set ts=2 sw=2 et: