summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-09-09 19:58:22 -0400
committerChris Severance2015-09-09 19:58:22 -0400
commitbdc5ff20319f14ccf8c46e94bbdc98c07008a804 (patch)
tree17e68617516e8b957a89dacf5316ec9f5c15cf68
downloadaur-bdc5ff20319f14ccf8c46e94bbdc98c07008a804.tar.gz
Initial Import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD51
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6546042c4e60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pdfminer
+ pkgdesc = python2 utils to extract, analyze text data of PDF files, including pdf2txt and dumppdf
+ pkgver = 20140328
+ pkgrel = 2
+ url = http://www.unixuser.org/~euske/python/pdfminer/
+ arch = any
+ license = MIT/X
+ makedepends = python2
+ makedepends = python2-distribute
+ source = http://pypi.python.org/packages/source/p/pdfminer/pdfminer-20140328.tar.gz
+ sha256sums = ba187b93056586a14edd5e630cf63ae96b1cc84b611f55dcddbc997316d9f262
+
+pkgname = pdfminer
+ depends = python2
+ provides = python2-pdfminer=20140328
+ conflicts = pdfminer
+ conflicts = python2-pdfminer
+ conflicts = python-pdfminer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05e953bc4c1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: BlackEagle < ike DOT devolder AT gmail DOT com >
+# Contributor: James Feng Cao
+
+_pyver="python2"
+_pyverother='python python2 '
+_pyverother="${_pyverother//${_pyver} /}"
+_pyverother="${_pyverother// /}"
+_pybase='pdfminer'
+_pkgname="${_pyver}-${_pybase}"
+pkgname="${_pybase}"
+pkgver='20140328'
+pkgrel='2'
+pkgdesc='python2 utils to extract, analyze text data of PDF files, including pdf2txt and dumppdf'
+arch=('any')
+#url="https://pypi.python.org/pypi/${_pybase}/"
+#url="https://github.com/euske/${_pybase}/"
+url="http://www.unixuser.org/~euske/python/${_pybase}/"
+license=('MIT/X')
+makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
+_srcdir="${_pybase}-${pkgver}"
+_verwatch=("https://pypi.python.org/simple/${_pybase}/" "${_pybase}-\([0-9\.]\+\)\.tar\.gz" 't')
+source=("http://pypi.python.org/packages/source/${_pybase: 0:1}/${_pybase}/${_pybase}-${pkgver}.tar.gz")
+sha256sums=('ba187b93056586a14edd5e630cf63ae96b1cc84b611f55dcddbc997316d9f262')
+
+build() {
+ set -u
+ cd "${_srcdir}"
+ ${_pyver} setup.py build
+ set +u
+}
+
+check() {
+ set -u
+ cd "${_srcdir}"
+ # If pip is installed, some package tests download missing packages. We can't allow that.
+ #${_pyver} setup.py test --verbose
+ set +u
+}
+
+package() {
+ set -u
+ provides=("${_pkgname}=${pkgver}")
+ conflicts=("${_pybase}" "${_pkgname}" "${_pyverother}-${_pybase}") # excessive for now, until we get a Python 3 compatible version
+ depends=("${_pyver}") # "${_pydepends[@]}")
+
+ cd "${_srcdir}"
+ ${_pyver} setup.py install --root="${pkgdir}"
+ #install -Dpm644 'LICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ set +u
+}