summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Gray2019-04-29 23:57:18 +0930
committerDaniel Gray2019-04-29 23:57:18 +0930
commit6167e9eb65726322494aba3d275037572d240a9d (patch)
tree66e6db4cf10fb98ba59a7188e6c45fb1bda4a8ea
downloadaur-6167e9eb65726322494aba3d275037572d240a9d.tar.gz
Initial contribution
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36347e6b19cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pdfmted-git
+ pkgdesc = View and modify PDF metadata on Linux graphically
+ pkgver = r6.a5d363d
+ pkgrel = 1
+ url = https://github.com/glutanimate/PDFMtEd
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = perl-image-exiftool
+ depends = python2
+ depends = qpdf
+ depends = yad
+ depends = xdg-utils
+ optdepends = java-sejda
+ source = pdfmted-git::git+https://github.com/glutanimate/pdfmted
+ sha256sums = SKIP
+
+pkgname = pdfmted-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b265648a209
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Daniel Gray <dng@disroot.org>
+pkgname=pdfmted-git
+pkgver=r6.a5d363d
+pkgrel=1
+pkgdesc="View and modify PDF metadata on Linux graphically"
+arch=("any")
+url="https://github.com/glutanimate/PDFMtEd"
+license=('GPL3')
+depends=('perl-image-exiftool' 'python2' 'qpdf' 'yad' 'xdg-utils')
+optdepends=('java-sejda')
+makedepends=('git')
+source=("${pkgname}::git+https://github.com/glutanimate/pdfmted")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm755 "${pkgname}"/pdfmted-editor -t "${pkgdir}"/usr/bin
+ install -Dm755 "${pkgname}"/pdfmted-inspector -t "${pkgdir}"/usr/bin
+ install -Dm755 "${pkgname}"/pdfmted-thumbnailer -t "${pkgdir}"/usr/bin
+ install -Dm644 "${pkgname}"/desktop/pdfmted-editor.desktop -t "${pkgdir}"/usr/share/applications
+ install -Dm644 "${pkgname}"/desktop/pdfmted-inspector.desktop -t "${pkgdir}"/usr/share/applications
+ install -Dm644 "${pkgname}"/desktop/pdfmted.png -t "${pkgdir}"/usr/share/icons/hicolor/scalable/apps/
+ install -Dm644 "${pkgname}"/desktop/pdfmted.svg -t "${pkgdir}"/usr/share/icons/hicolor/scalable/apps/
+}