summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-06-12 08:18:34 +1200
committercaltlgin2020-06-12 08:18:34 +1200
commit33ab3677c4fc15f618a19589a41d0792b794dd06 (patch)
tree58526db2454bc2f197d88262f889f50ec4fae990
downloadaur-33ab3677c4fc15f618a19589a41d0792b794dd06.tar.gz
Add to AUR
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3a682e4fc73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pdfquirk-git
+ pkgdesc = Create PDFs from images or scanner
+ pkgver = continuous.r0.g0d79759
+ pkgrel = 1
+ url = https://dragotin.github.io/quirksite/
+ arch = x86_64
+ license = GPL3
+ makedepends = extra-cmake-modules
+ makedepends = glu
+ makedepends = qt5-base
+ depends = git
+ depends = imagemagick
+ optdepends = sane: scanning support
+ provides = pdfquirk
+ conflicts = pdfquirk
+ source = git+https://github.com/dragotin/pdfquirk.git
+ sha256sums = SKIP
+
+pkgname = pdfquirk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6188b9481c52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname=pdfquirk
+pkgname=${_pkgname}-git
+pkgver=continuous.r0.g0d79759
+pkgrel=1
+pkgdesc="Create PDFs from images or scanner"
+arch=('x86_64')
+url="https://dragotin.github.io/quirksite/"
+license=('GPL3')
+source=("git+https://github.com/dragotin/${_pkgname}.git")
+depends=('git' 'imagemagick')
+optdepends=('sane: scanning support')
+makedepends=('extra-cmake-modules' 'glu' 'qt5-base')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_pkgname}"
+ cmake . -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR=${pkgdir} install
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+} \ No newline at end of file