summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-11-24 10:48:35 -0500
committerCarlos Aznarán Laos2021-11-24 10:48:35 -0500
commitb732589f698511db13e370cbd67f0e11eafb9594 (patch)
treedadb28d32d225dc15326501dab812e44ef782a11
parentecebf1c15533c2b8e87c9a141238c9e1ad1be5a1 (diff)
downloadaur-b732589f698511db13e370cbd67f0e11eafb9594.tar.gz
Build pdfquirk with Qt6
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD50
3 files changed, 32 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c73c640068f7..edf200523785 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = pdfquirk-git
- pkgdesc = Create PDFs from images or scanner
- pkgver = r35.0d79759
- pkgrel = 2
- url = https://dragotin.github.io/quirksite/
+ pkgdesc = Creating PDFs from images or scanner made easy
+ pkgver = continuous.r13.g157f773
+ pkgrel = 1
+ url = https://dragotin.github.io/quirksite
arch = x86_64
license = GPL3
makedepends = extra-cmake-modules
- makedepends = git
makedepends = glu
+ makedepends = git
depends = hicolor-icon-theme
depends = imagemagick
- depends = qt5-base
+ depends = qt6-tools
optdepends = sane: scanning support
provides = pdfquirk
source = git+https://github.com/dragotin/pdfquirk.git
- sha256sums = SKIP
+ sha512sums = SKIP
pkgname = pdfquirk-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 49188d1eb58a..f2e829e95194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,36 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
-
-_pkgname=pdfquirk
-pkgname=${_pkgname}-git
-pkgver=r35.0d79759
-pkgrel=2
-pkgdesc='Create PDFs from images or scanner'
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
+pkgname=pdfquirk-git
+pkgver=continuous.r13.g157f773
+pkgrel=1
+pkgdesc="Creating PDFs from images or scanner made easy"
arch=('x86_64')
-url='https://dragotin.github.io/quirksite/'
-license=('GPL3')
-depends=('hicolor-icon-theme' 'imagemagick' 'qt5-base')
-makedepends=('extra-cmake-modules' 'git' 'glu')
+url="https://dragotin.github.io/quirksite"
+license=(GPL3)
+depends=(hicolor-icon-theme imagemagick qt6-tools)
+makedepends=(extra-cmake-modules glu git)
optdepends=('sane: scanning support')
-provides=("${_pkgname}")
-source=("git+https://github.com/dragotin/${_pkgname}.git")
-sha256sums=('SKIP')
+provides=("${pkgname/-git/}")
+source=("git+https://github.com/dragotin/${pkgname/-git/}.git")
+sha512sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${pkgname/-git/}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- export CFLAGS+=" ${CPPFLAGS}"
- export CXXFLAGS+=" ${CPPFLAGS}"
- cmake -B build -S "${_pkgname}" \
- -DCMAKE_BUILD_TYPE='None' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
+ cmake \
+ -S "${pkgname/-git/}" \
+ -B build \
+ -DUSE_QT6=yes \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-Wno-dev
- make -C build
+ cmake --build build --target all
}
package() {
- make DESTDIR="${pkgdir}" PREFIX="/usr" -C build install
- install -Dm644 "${_pkgname}/README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ DESTDIR="${pkgdir}" cmake --build build --target install
+ install -Dm644 "${pkgname/-git/}/README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
}
-
-# vim: ts=2 sw=2 et: \ No newline at end of file