summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-05-13 22:51:14 +0200
committerNarrat2015-05-13 22:51:14 +0200
commit1d57ba1b276d8292eff9988c5a2571b7bf707243 (patch)
treeca12487536a9a797c64d4f3ee7fe18c3caba3304
downloadaur-1d57ba1b276d8292eff9988c5a2571b7bf707243.tar.gz
pdfresurrect: Latest files
History: https://github.com/Narrat/PKGBuilds
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore14
-rw-r--r--01_Makefile.patch13
-rw-r--r--PKGBUILD33
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f251ccea1c29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pdfresurrect
+ pkgdesc = PDFResurrect is a tool aimed at analyzing PDF documents
+ pkgver = 0.12
+ pkgrel = 1
+ url = http://757labs.org/wiki/Projects/pdfresurrect
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ depends = glibc
+ source = pdfresurrect-0.12.tar.gz::https://github.com/enferex/pdfresurrect/archive/v0.12.tar.gz
+ source = 01_Makefile.patch
+ md5sums = 01223952c2b9b46f7a80ea1aece791c1
+ md5sums = 550daedf7a2fa3a948447f881bd03e1f
+
+pkgname = pdfresurrect
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3a3642b6f6ff
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*/src
+*/pkg
+*.gz
+*.xz
+*.bz2
+*.zip
+*.part
+*.sig
+*.sign
+*.txt
+*.log
+*.scm
+*/*.pkg
+*/*.asc
diff --git a/01_Makefile.patch b/01_Makefile.patch
new file mode 100644
index 000000000000..f11947a70dab
--- /dev/null
+++ b/01_Makefile.patch
@@ -0,0 +1,13 @@
+--- pdfresurrect-0.12/Makefile.in
++++ pdfresurrect-0.12/Makefile.in
+@@ -15,8 +15,8 @@
+ $(CC) -o $@ -c $< $(CFLAGS)
+
+ install:
+- cp $(APP) $(DESTDIR)$(PREFIX)/bin/
+- cp $(MANPAGE) $(DESTDIR)$(PREFIX)/man/man1/
++ install -D $(APP) $(DESTDIR)$(PREFIX)/bin/$(APP)
++ install -D $(MANPAGE) $(DESTDIR)$(PREFIX)/man/man1/$(MANPAGE)
+
+ uninstall:
+ rm $(DESTDIR)$(PREFIX)/bin/$(APP)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8eaf19ef6fe8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Lex Black <autumn-wind at web dot de>
+# Contributor: Patrick Hof <patrickhof@web.de>
+
+pkgname=pdfresurrect
+pkgver=0.12
+pkgrel=1
+pkgdesc="PDFResurrect is a tool aimed at analyzing PDF documents"
+url="http://757labs.org/wiki/Projects/pdfresurrect"
+license=("GPL3")
+arch=('x86_64' 'i686')
+depends=('glibc')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/enferex/$pkgname/archive/v$pkgver.tar.gz"
+ '01_Makefile.patch')
+md5sums=('01223952c2b9b46f7a80ea1aece791c1'
+ '550daedf7a2fa3a948447f881bd03e1f')
+
+
+prepare() {
+ patch -p0 < 01_Makefile.patch
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ make DESTDIR=$pkgdir install
+}