summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Scholz2023-11-06 13:43:47 +0100
committerChristoph Scholz2023-11-06 13:43:47 +0100
commitbf4b3fd3af85246500dc26f6f9c3117d666ce169 (patch)
tree4c09fc65f82c6c5b8437d41fac9b746bd6d18d1d
parentf70df710ab5754d97b9d591ce1305970d2ee5c79 (diff)
downloadaur-bf4b3fd3af85246500dc26f6f9c3117d666ce169.tar.gz
update to v5.2.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
-rw-r--r--pdfsam2
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85ba682abf8b..92858df14a15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = pdfsam
pkgdesc = A free open source tool to split and merge pdf documents
- pkgver = 5.1.3
- pkgrel = 3
+ pkgver = 5.2.0
+ pkgrel = 1
url = https://www.pdfsam.org/
arch = any
license = AGPL3
makedepends = desktop-file-utils
makedepends = gendesk
depends = hicolor-icon-theme
- depends = java-runtime=20
+ depends = java-runtime=21
depends = sh
depends = archlinux-java-run
- noextract = pdfsam-5.1.3-linux.tar.gz
- source = https://github.com/torakiki/pdfsam/releases/download/v5.1.3/pdfsam-5.1.3-linux.tar.gz
+ noextract = pdfsam-5.2.0-linux.tar.gz
+ source = https://github.com/torakiki/pdfsam/releases/download/v5.2.0/pdfsam-5.2.0-linux.tar.gz
source = pdfsam
- sha512sums = 757a02ca1fa72b0303d46e1c5940a7a940d092914c3866e58fad4b1bcc21da582a9f8379906c58d3c6426cbdf931b979d0797419b46f1f3fac683480cc740ea6
- sha512sums = ec0703ff11e69e0d1dac5e1a4c8671d7994b340947cc1bbeed1ff80d598fd98ae4e74a9ac29489df8432336bf8b439e0fc18b8f295eb70f3a3f06d54cf6a8aa9
+ sha512sums = be9acc57b1d5a0fe64c0bd08c64372a6818658b635cdd34841d927be4bedb0b45cb9dbce9352f771e7bab536d054f199fd7bec5ae97223c373de6076ce729d9a
+ sha512sums = 700700b8ad4fb44f6eb1aaff35ede7ac53729c0dce39f23467159b14aadd28705cf5c547c6b8871ecd4afebc1fb479eafdbdad68b95c0114e26438961abf8209
pkgname = pdfsam
diff --git a/PKGBUILD b/PKGBUILD
index c6220752af16..6c5c8a8b4a1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
# Contributor: Tom <reztho at archlinux dot us>
pkgname=pdfsam
-pkgver=5.1.3
-pkgrel=3
+pkgver=5.2.0
+pkgrel=1
pkgdesc="A free open source tool to split and merge pdf documents"
arch=('any')
url="https://www.pdfsam.org/"
license=('AGPL3')
-depends=('hicolor-icon-theme' 'java-runtime=20' 'sh' 'archlinux-java-run')
+depends=('hicolor-icon-theme' 'java-runtime=21' 'sh' 'archlinux-java-run')
makedepends=('desktop-file-utils' 'gendesk')
source=("https://github.com/torakiki/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}-linux.tar.gz"
"pdfsam")
-sha512sums=('757a02ca1fa72b0303d46e1c5940a7a940d092914c3866e58fad4b1bcc21da582a9f8379906c58d3c6426cbdf931b979d0797419b46f1f3fac683480cc740ea6'
- 'ec0703ff11e69e0d1dac5e1a4c8671d7994b340947cc1bbeed1ff80d598fd98ae4e74a9ac29489df8432336bf8b439e0fc18b8f295eb70f3a3f06d54cf6a8aa9')
+sha512sums=('be9acc57b1d5a0fe64c0bd08c64372a6818658b635cdd34841d927be4bedb0b45cb9dbce9352f771e7bab536d054f199fd7bec5ae97223c373de6076ce729d9a'
+ '700700b8ad4fb44f6eb1aaff35ede7ac53729c0dce39f23467159b14aadd28705cf5c547c6b8871ecd4afebc1fb479eafdbdad68b95c0114e26438961abf8209')
noextract=("${pkgname}-${pkgver}-linux.tar.gz")
prepare() {
diff --git a/pdfsam b/pdfsam
index a8593e0c4292..5be70441e09e 100644
--- a/pdfsam
+++ b/pdfsam
@@ -1,5 +1,5 @@
#!/bin/sh
-JAVA_HOME=$(archlinux-java-run --min 20 --max 20 --java-home) && \
+JAVA_HOME=$(archlinux-java-run --min 21 --max 21 --java-home) && \
exec $JAVA_HOME/bin/java --enable-preview --module-path "/usr/share/java/pdfsam" --module org.pdfsam.basic/org.pdfsam.basic.App -Xmx512M \
-splash:/usr/share/pdfsam/splash.png \
-Dapp.name="pdfsam-basic" \