summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlamus Diu2018-06-08 21:16:50 +0000
committerFlamus Diu2018-06-08 21:16:50 +0000
commit8d882e2d4f7a294cec6c918fc6a05a93bc83c453 (patch)
tree5bda6f0151bbc5c1284e7be25233e7cc753b40e0
downloadaur-8d882e2d4f7a294cec6c918fc6a05a93bc83c453.tar.gz
Cloned from PDFStudio package and updated to 12.0.7
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD48
-rw-r--r--pdfstudio12.desktop9
-rw-r--r--pdfstudio12.install33
-rw-r--r--pdfstudio12.pngbin0 -> 5312 bytes
5 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d07f36e12b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = pdfstudio12
+ pkgdesc = Review, annotate, and edit PDF Documents
+ pkgver = 12.0.7
+ pkgrel = 1
+ url = http://www.qoppa.com/pdfstudio/
+ install = pdfstudio12.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = pacman>=4.2.0
+ depends = java-runtime>=6
+ depends = desktop-file-utils
+ provides = pdfstudio
+ conflicts = pdfstudio
+ conflicts = pdfstudio11
+ conflicts = pdfstudio8
+ conflicts = pdfstudio9
+ conflicts = pdfstudio10
+ source = pdfstudio12.desktop
+ source = pdfstudio12.install
+ source = pdfstudio12.png
+ sha256sums = 454fbc31f8951f3affcaa0c432b78591a3012a428768f196face44c03b5709ec
+ sha256sums = b82acfb50e1e15a43c54aba7a0712b6c710c10ae74280a26a451343720e965e3
+ sha256sums = 0a3c1c337a22228f3df28412ca65d45d0d8067b508cf7b1cf93810fc17c9b447
+ source_i686 = http://download.qoppa.com/pdfstudio/v12/PDFStudio_v12_0_7_linux.deb
+ sha256sums_i686 = 7148512e9e390edbc70d1d0bb054dad758fb8599eaf6ba8aae7792a640bc4739
+ source_x86_64 = http://download.qoppa.com/pdfstudio/v12/PDFStudio_v12_0_7_linux64.deb
+ sha256sums_x86_64 = ddc15071362a904bc6d066c3f7969a8d309f78dac2adae1bcf6a57349f8b0b80
+
+pkgname = pdfstudio12
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b1bb901ae47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Jesse Spangenberger <azulephoenix@gmail.com>
+# Contributor: Tristelune <tristelune@archlinux.info>
+pkgname=pdfstudio12
+pkgver=12.0.7
+_pkgver=v12_0_7
+pkgrel=1
+pkgdesc="Review, annotate, and edit PDF Documents"
+arch=('i686' 'x86_64')
+url="http://www.qoppa.com/pdfstudio/"
+license=('custom')
+conflicts=('pdfstudio' 'pdfstudio11' 'pdfstudio8' 'pdfstudio9' 'pdfstudio10')
+provides=('pdfstudio')
+makedepends=('pacman>=4.2.0')
+depends=('java-runtime>=6' 'desktop-file-utils')
+
+install=${pkgname}.install
+
+sha256sums=('454fbc31f8951f3affcaa0c432b78591a3012a428768f196face44c03b5709ec'
+ 'b82acfb50e1e15a43c54aba7a0712b6c710c10ae74280a26a451343720e965e3'
+ '0a3c1c337a22228f3df28412ca65d45d0d8067b508cf7b1cf93810fc17c9b447')
+sha256sums_i686=('7148512e9e390edbc70d1d0bb054dad758fb8599eaf6ba8aae7792a640bc4739')
+sha256sums_x86_64=('ddc15071362a904bc6d066c3f7969a8d309f78dac2adae1bcf6a57349f8b0b80')
+source_i686=("http://download.qoppa.com/pdfstudio/v12/PDFStudio_${_pkgver}_linux.deb")
+source_x86_64=("http://download.qoppa.com/pdfstudio/v12/PDFStudio_${_pkgver}_linux64.deb")
+source=(${pkgname}.desktop
+ ${pkgname}.install
+ ${pkgname}.png)
+
+prepare() {
+ bsdtar xf data.tar.gz
+ bsdtar xf "opt/pdfstudio12/lib/pdfstudio.jar" resources/license.html
+
+ rm -rf "opt/pdfstudio12/jre"
+}
+
+package() {
+
+ cd "${srcdir}"
+
+ install -dm 755 "${pkgdir}/opt"
+ install -Dm644 ${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 ${pkgname}.png "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 resources/license.html "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.html"
+
+ cp -r opt/ "${pkgdir}"
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s /opt/pdfstudio12/pdfstudio12 "${pkgdir}/usr/bin/pdfstudio"
+}
diff --git a/pdfstudio12.desktop b/pdfstudio12.desktop
new file mode 100644
index 000000000000..91da9bd61540
--- /dev/null
+++ b/pdfstudio12.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=PDF Studio 12
+Comment=Views and Edits Adobe PDF (acrobat) files
+Exec=pdfstudio %f
+Terminal=false
+Type=Application
+Icon=pdfstudio
+Categories=Office;
+MimeType=application/pdf;
diff --git a/pdfstudio12.install b/pdfstudio12.install
new file mode 100644
index 000000000000..f5d129e3dbe3
--- /dev/null
+++ b/pdfstudio12.install
@@ -0,0 +1,33 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${BLUE}==>${ALL_OFF}${BOLD} $1${ALL_OFF}\n"
+}
+
+note() {
+ printf "${BLUE}==>${ALL_OFF}${YELLOW} NOTE:${ALL_OFF}${BOLD} $1${ALL_OFF}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="$(tput bold)"
+BLUE="${BOLD}$(tput setaf 4)"
+YELLOW="${BOLD}$(tput setaf 3)"
+
+_update() {
+ msg_blue "Updating desktop MIME database..."
+ update-desktop-database -q
+ msg_blue "Updating icon cache.."
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_install() {
+ _update
+ note "The binary is called: 'pdfstudio'"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ _update
+}
diff --git a/pdfstudio12.png b/pdfstudio12.png
new file mode 100644
index 000000000000..0a0298cf94ee
--- /dev/null
+++ b/pdfstudio12.png
Binary files differ