summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-07-25 12:38:58 -0600
committeryochananmarqos2019-07-25 12:38:58 -0600
commited0f25b7afeeadbca66f2b2c473b6fb61306b14f (patch)
tree3f371e9458477b09d276ab4d53517e2907fa7dd7
downloadaur-ed0f25b7afeeadbca66f2b2c473b6fb61306b14f.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
-rw-r--r--pdfstudioviewer.desktop9
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bded99c2857f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pdfstudioviewer
+ pkgdesc = Review, annotate, and edit PDF Documents
+ pkgver = 2019.1.0
+ pkgrel = 1
+ url = https://www.qoppa.com/pdfstudioviewer
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = java-runtime<=8
+ depends = desktop-file-utils
+ depends = sane
+ source = pdfstudioviewer.desktop
+ sha256sums = 366e4cc2c4db9bbb3baa0901b2a22a4e8ee0b2093d6e13e7c9558e6e28555f86
+ source_i686 = pdfstudioviewer-2019.1.0_linux.deb::https://download.qoppa.com/pdfstudioviewer/PDFStudioViewer_linux.deb
+ sha256sums_i686 = 8e4c625e8d71be395454a4a6e214785534361fc3c6953f507839ee529df813b6
+ source_x86_64 = pdfstudioviewer-2019.1.0_linux64.deb::https://download.qoppa.com/pdfstudioviewer/PDFStudioViewer_linux64.deb
+ sha256sums_x86_64 = f2386b37aec0721fbd0dc6a29ff67a57ecbb5c3e45396e33cddc728549ce5d97
+
+pkgname = pdfstudioviewer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ab0416abe8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=pdfstudioviewer
+_pkgname=pdfstudioviewer2019
+pkgver=2019.1.0
+pkgrel=1
+pkgdesc="Review, annotate, and edit PDF Documents"
+arch=('i686' 'x86_64')
+url="https://www.qoppa.com/pdfstudioviewer"
+license=('custom')
+depends=('java-runtime<=8' 'desktop-file-utils' 'sane')
+source_i686=("${pkgname}-${pkgver}_linux.deb::https://download.qoppa.com/$pkgname/PDFStudioViewer_linux.deb")
+source_x86_64=("${pkgname}-${pkgver}_linux64.deb::https://download.qoppa.com/$pkgname/PDFStudioViewer_linux64.deb")
+source=("$pkgname.desktop")
+sha256sums_i686=('8e4c625e8d71be395454a4a6e214785534361fc3c6953f507839ee529df813b6')
+sha256sums_x86_64=('f2386b37aec0721fbd0dc6a29ff67a57ecbb5c3e45396e33cddc728549ce5d97')
+sha256sums=('366e4cc2c4db9bbb3baa0901b2a22a4e8ee0b2093d6e13e7c9558e6e28555f86')
+
+prepare() {
+ bsdtar xf data.tar.gz
+ bsdtar xf "opt/$_pkgname/lib/pdfstudio.jar" resources/license.html
+
+ rm -rf "opt/$_pkgname/jre"
+ rm "opt/$_pkgname/updater"
+}
+
+package() {
+ install -dm 755 "$pkgdir/opt/$pkgname"
+ cp -r "opt/$_pkgname/." "$pkgdir/opt/$pkgname/"
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "opt/$_pkgname/.install4j/$_pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 resources/license.html "$pkgdir/usr/share/licenses/$pkgname/LICENSE.html"
+ install -d "$pkgdir/usr/bin"
+ ln -sf "/opt/$pkgname/$_pkgname" "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/pdfstudioviewer.desktop b/pdfstudioviewer.desktop
new file mode 100644
index 000000000000..4f8acc1dd389
--- /dev/null
+++ b/pdfstudioviewer.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=PDF Studio Viewer 2019
+Comment=Views and Edits Adobe PDF (acrobat) files
+Exec=pdfstudioviewer %f
+Terminal=false
+Type=Application
+Icon=pdfstudioviewer
+Categories=Office;
+MimeType=application/pdf;