summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Dumont2015-06-11 16:11:59 -0400
committerJoey Dumont2015-06-11 16:11:59 -0400
commit35545248e8e5ffd6ff656b79944337aad5f9d10d (patch)
treec46fe1bda6303523f963e15bb315d31c0949e7e2
downloadaur-35545248e8e5ffd6ff656b79944337aad5f9d10d.tar.gz
Pushed package to AUR4.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore10
-rw-r--r--Makefile.Arch19
-rw-r--r--PKGBUILD47
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc30de6b2b0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pdftk
+ pkgdesc = Pdftk is a simple tool for doing everyday things with PDF documents
+ pkgver = 2.02
+ pkgrel = 4
+ url = http://www.pdfhacks.com/pdftk
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gcc-gcj=5.1.0
+ depends = gcc-gcj-ecj
+ options = !makeflags
+ source = http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/pdftk-2.02-src.zip
+ source = Makefile.Arch
+ sha1sums = a4a27e984c5e1401cfa44b8e92a64113d7396a06
+ sha1sums = 95d55ad8ea8dfcb44bdd4af3954868ca10b1cad1
+
+pkgname = pdftk
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..67f8c18f0637
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+*.jar
+pkg/
+src/ \ No newline at end of file
diff --git a/Makefile.Arch b/Makefile.Arch
new file mode 100644
index 000000000000..8c241a462988
--- /dev/null
+++ b/Makefile.Arch
@@ -0,0 +1,19 @@
+# Based on 'Makefile.Debian', part of pdftk
+# Copyright (c) 2004-2012 Sid Steward
+
+export CXX= g++
+export GCJ= gcj
+export GCJH= gcjh
+export GJAR= gjar
+export LIBGCJ= /usr/share/java/libgcj.jar
+export AR= ar
+export RM= rm
+export ARFLAGS= rs
+export RMFLAGS= -vf
+export CPPFLAGS= -DPATH_DELIM=0x2f -DASK_ABOUT_WARNINGS=false -DUNBLOCK_SIGNALS -fdollars-in-identifiers
+export CXXFLAGS= -O2
+export GCJFLAGS= -Wno-all -fsource=1.3 -O2
+export GCJHFLAGS= -force
+export LDLIBS= -lgcj
+
+include Makefile.Base
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a956b565583
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Joey Dumont <joey.dumont@gmail.com>
+# Contributor: osc
+# Contributor: StefanHusmann
+# Contributor: larsrh <hupel@in.tum.de>
+
+pkgname=pdftk
+pkgver=2.02
+pkgrel=4
+pkgdesc="Pdftk is a simple tool for doing everyday things with PDF documents"
+arch=('i686' 'x86_64')
+url="http://www.pdfhacks.com/pdftk"
+license="GPL"
+depends=('gcc-gcj=5.1.0' 'gcc-gcj-ecj')
+options=('!makeflags')
+source=("http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/${pkgname}-${pkgver}-src.zip"
+ "Makefile.Arch"
+)
+sha1sums=('a4a27e984c5e1401cfa44b8e92a64113d7396a06'
+ '95d55ad8ea8dfcb44bdd4af3954868ca10b1cad1')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver-dist/$pkgname"
+ cp "$srcdir/Makefile.Arch" .
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver-dist/$pkgname"
+ make -f Makefile.Arch
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver-dist/$pkgname"
+
+ # Install binary
+ install -D -m 755 pdftk $pkgdir/usr/bin/pdftk
+
+ # Install licenses and adjust permissions
+ cd ..
+ LICENSE_DIR="$pkgdir/usr/share/licenses/$pkgname"
+ mkdir -p "$LICENSE_DIR"
+ cp -R license_gpl_pdftk/* "$LICENSE_DIR"
+ chmod -R 0755 "$LICENSE_DIR"
+ find "$LICENSE_DIR" -type f -exec chmod -x {} \;
+
+ # Install manpage
+ install -D -m 644 "pdftk.1" "$pkgdir/usr/share/man/man1/pdftk.1"
+}