summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-18 09:17:53 +0800
committerzxp198210052023-07-18 09:17:53 +0800
commit4a64f955c475ffb52966e70db6ed1597e4692892 (patch)
treed70ea31fb4df105267fe7f1a86cd86fa57388125
downloadaur-4a64f955c475ffb52966e70db6ed1597e4692892.tar.gz
first release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
-rw-r--r--pdmaner.sh8
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d48fb04ef7bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pdmaner-bin
+ pkgdesc = A multi operating system open source and free desktop version relational database modeling tool.一款多操作系统开源免费的桌面版关系数据库模型建模工具
+ pkgver = 4.6.0
+ pkgrel = 1
+ url = http://www.pdmaner.com
+ arch = x86_64
+ license = MPL2
+ depends = bash
+ depends = electron13
+ depends = java-runtime
+ provides = pdmaner
+ conflicts = pdmaner
+ source = pdmaner-4.6.0.AppImage::https://github.com/zxp19821005/My_AUR_Files/releases/download/v4.6.0/PDManer-linux_v4.6.0.AppImage
+ source = LICENSE::https://gitee.com/robergroup/pdmaner/raw/master/LICENSE
+ source = pdmaner.sh
+ sha256sums = 5bf70f02f950d653820bfaf17460f3c472a25385a5dcc8f813052cd1e0be1be1
+ sha256sums = 05eec509c11d99970dc4ca5bed4aae992960fd7f168e1746089c49643a18f461
+ sha256sums = ff82429b6f757ef0e138d6079b27d7e282d41e12a7ad9c9577a40d580db52acf
+
+pkgname = pdmaner-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d32b7b7e846
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="pdmaner-bin"
+pkgver=4.6.0
+pkgrel=1
+pkgdesc="A multi operating system open source and free desktop version relational database modeling tool.一款多操作系统开源免费的桌面版关系数据库模型建模工具"
+arch=("x86_64")
+url="http://www.pdmaner.com"
+_downurl="https://github.com/zxp19821005/My_AUR_Files"
+license=("MPL2")
+depends=('bash' 'electron13' 'java-runtime')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("${pkgname%-bin}-${pkgver}.AppImage::${_downurl}/releases/download/v${pkgver}/PDManer-linux_v${pkgver}.AppImage"
+ "LICENSE::https://gitee.com/robergroup/pdmaner/raw/master/LICENSE"
+ "${pkgname%-bin}.sh")
+sha256sums=('5bf70f02f950d653820bfaf17460f3c472a25385a5dcc8f813052cd1e0be1be1'
+ '05eec509c11d99970dc4ca5bed4aae992960fd7f168e1746089c49643a18f461'
+ 'ff82429b6f757ef0e138d6079b27d7e282d41e12a7ad9c9577a40d580db52acf')
+
+prepare() {
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ cp -r "${srcdir}/squashfs-root/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
+ sed "s|AppRun --no-sandbox %U|opt/${pkgname%-bin}/${pkgname%-bin}|g;s|Utility|Utility;Development|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ find "${pkgdir}/opt/${pkgname%-bin}" -type d -exec chmod 755 {} \;
+} \ No newline at end of file
diff --git a/pdmaner.sh b/pdmaner.sh
new file mode 100644
index 000000000000..c16d06b3a12d
--- /dev/null
+++ b/pdmaner.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+_ELECTRON=/usr/bin/electron13
+_ASAR="/opt/pdmaner/pdmaner.asar"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec ${_ELECTRON} ${_ASAR} "$@"
+else
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+fi \ No newline at end of file