summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-05 10:49:40 +0800
committerzxp198210052024-01-05 10:49:40 +0800
commitda65026a53033ad84664a65367b7f30a876737af (patch)
tree17a913bc0a219169ee3f027409ab11a5b10c71f1
parent0c6170b15ba67260bc64ada4f5ea95ed013cc6f0 (diff)
downloadaur-da65026a53033ad84664a65367b7f30a876737af.tar.gz
update to 4.7.0
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
-rw-r--r--pdmaner.sh22
3 files changed, 40 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb6fed724212..297798e21baf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,23 @@
pkgbase = pdmaner-bin
pkgdesc = A multi operating system open source and free desktop version relational database modeling tool.一款多操作系统开源免费的桌面版关系数据库模型建模工具
- pkgver = 4.6.3
- pkgrel = 2
+ pkgver = 4.7.0
+ pkgrel = 1
url = http://www.pdmaner.com
arch = x86_64
license = MPL2
makedepends = squashfuse
depends = electron13
- depends = libx11
- depends = gdk-pixbuf2
- depends = libxext
+ depends = dbus-glib
depends = libdbusmenu-glib
depends = gtk2
- depends = dbus-glib
- provides = pdmaner=4.6.3
+ depends = java-runtime
+ provides = pdmaner=4.7.0
conflicts = pdmaner
- source = pdmaner-4.6.3.AppImage::https://github.com/zxp19821005/My_AUR_Files/releases/download/v4.6.3/PDManer-linux_v4.6.3.AppImage
- source = LICENSE::https://gitee.com/robergroup/pdmaner/raw/master/LICENSE
+ source = pdmaner-4.7.0.AppImage::https://github.com/zxp19821005/My_AUR_Files/releases/download/v4.7.0/PDManer-linux_v4.7.0.AppImage
+ source = LICENSE-4.7.0::https://gitee.com/robergroup/pdmaner/raw/master/LICENSE
source = pdmaner.sh
- sha256sums = 19337a28b8071b32594ee7da87298fa058be409d1031b9f07326c586ff93155c
- sha256sums = 05eec509c11d99970dc4ca5bed4aae992960fd7f168e1746089c49643a18f461
- sha256sums = 893e9e7caeceb1eb2211915922da99337350327146b1c5876337d4c5df6adde5
+ sha256sums = 0cefaaddb2296f85f203961aef70520fbd9304ae971d7545dc7356fa296dc3b1
+ sha256sums = 7c91afc2c15fc478de3fc38f2678e560906859da6932f2c03b6bc9076d592d18
+ sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
pkgname = pdmaner-bin
diff --git a/PKGBUILD b/PKGBUILD
index 353bb90ad4ee..6d01ffe5e48e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=pdmaner-bin
_appname=PDManer
-pkgver=4.6.3
-pkgrel=2
+pkgver=4.7.0
+_electronversion=13
+pkgrel=1
pkgdesc="A multi operating system open source and free desktop version relational database modeling tool.一款多操作系统开源免费的桌面版关系数据库模型建模工具"
arch=("x86_64")
url="http://www.pdmaner.com"
@@ -11,29 +12,31 @@ license=("MPL2")
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- 'electron13'
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
+ "electron${_electronversion}"
+ 'dbus-glib'
'libdbusmenu-glib'
'gtk2'
- 'dbus-glib'
+ 'java-runtime'
)
makedepends=(
'squashfuse'
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${_downurl}/releases/download/v${pkgver}/${_appname}-linux_v${pkgver}.AppImage"
- "LICENSE::https://gitee.com/robergroup/pdmaner/raw/master/LICENSE"
+ "LICENSE-${pkgver}::https://gitee.com/robergroup/pdmaner/raw/master/LICENSE"
"${pkgname%-bin}.sh"
)
-sha256sums=('19337a28b8071b32594ee7da87298fa058be409d1031b9f07326c586ff93155c'
- '05eec509c11d99970dc4ca5bed4aae992960fd7f168e1746089c49643a18f461'
- '893e9e7caeceb1eb2211915922da99337350327146b1c5876337d4c5df6adde5')
+sha256sums=('0cefaaddb2296f85f203961aef70520fbd9304ae971d7545dc7356fa296dc3b1'
+ '7c91afc2c15fc478de3fc38f2678e560906859da6932f2c03b6bc9076d592d18'
+ '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g;s|Utility|Utility;Development|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g;s|Utility|Utility;Development|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
find "${srcdir}/squashfs-root/resources" -type d -exec chmod 755 {} \;
}
package() {
@@ -44,5 +47,5 @@ package() {
install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file
diff --git a/pdmaner.sh b/pdmaner.sh
index ab0f2c42baf2..c77c53567639 100644
--- a/pdmaner.sh
+++ b/pdmaner.sh
@@ -1,11 +1,17 @@
-#!/bin/bash
-_ELECTRON=/usr/bin/electron13
-APPDIR=/usr/lib/pdmaner
-export PATH="${APPDIR}:${PATH}"
-export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${APPDIR}/app.asar"
+#!/bin/sh
+set -e
+_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
+ exit
else
- exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
+ exit
fi \ No newline at end of file