summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordrrossum2017-08-28 09:41:21 +0200
committerdrrossum2017-08-28 09:41:21 +0200
commit988119d65095a1ab69aebd81b5d47df4d51c3d37 (patch)
treed684175f9062013fcf8c2590e50910493c4f2904
parent8555b661f470f93fe18493ee67c8d1fd5e62205e (diff)
downloadaur-988119d65095a1ab69aebd81b5d47df4d51c3d37.tar.gz
fix missing configure script with makedepend autoconf
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90a4b2fcc5bf..3a8bfdf0bc93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Aug 25 07:00:49 UTC 2017
+# Mon Aug 28 07:40:11 UTC 2017
pkgbase = pdsh
pkgdesc = Parallel Distributed Shell
pkgver = 2.32
@@ -8,6 +8,7 @@ pkgbase = pdsh
arch = i686
arch = x86_64
license = GPL
+ makedepends = autoconf
depends = glibc
depends = openssh
depends = readline
diff --git a/PKGBUILD b/PKGBUILD
index 72c14beb6b74..e78448a4779c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,6 +9,7 @@ url='https://github.com/grondo/pdsh'
arch=('i686' 'x86_64')
license=('GPL')
depends=('glibc' 'openssh' 'readline')
+makedepends=('autoconf')
optdepends=('perl: required by the dshbak utility')
options=('libtool')
source=("https://github.com/grondo/pdsh/archive/pdsh-2.32.tar.gz")
@@ -16,6 +17,7 @@ md5sums=('3af36658154e2983c9e4067f91672c54')
build() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
+ autoreconf -fiv
./configure --prefix=/usr --mandir=/usr/share/man \
--without-rsh \
--with-ssh \
@@ -27,7 +29,7 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}/" install || return 1
- rmdir "${pkgdir}/usr/sbin"
+ #rmdir "${pkgdir}/usr/sbin"
}
# vim:set ts=2 sw=2 et: