summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2013-11-03 01:10:22 +0100
committerHyacinthe Cartiaux2015-06-09 14:05:40 +0200
commit3f6c29eb4be5df960b5ea05f8644794a19df185d (patch)
tree60990a31dd4f50eabe93c7195a6d308648e6b106
parent6be9f823c5c6038bcea749367d292fd9499ec241 (diff)
downloadaur-3f6c29eb4be5df960b5ea05f8644794a19df185d.tar.gz
[pdsh-genders] Update to 2.29
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD33
2 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56922d65d305..2036fdaa2a17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = pdsh-genders
- pkgdesc = A high-performance, parallel remote shell utility
- pkgver = 2.22
+ pkgdesc = Parallel Distributed Shell
+ pkgver = 2.29
pkgrel = 1
- url = https://computing.llnl.gov/linux/pdsh.html
+ url = http://code.google.com/p/pdsh/
arch = i686
arch = x86_64
license = GPL
@@ -11,10 +11,11 @@ pkgbase = pdsh-genders
depends = readline
depends = genders
optdepends = perl: required by the dshbak utility
+ provides = pdsh
conflicts = pdsh
options = libtool
- source = http://downloads.sourceforge.net/pdsh/pdsh-2.22.tar.bz2
- md5sums = 151b7a67079e88da0309a5c60432f4a9
+ source = http://pdsh.googlecode.com/files/pdsh-2.29.tar.bz2
+ md5sums = e3512d03e491de6f1a735ab0ff702108
pkgname = pdsh-genders
diff --git a/PKGBUILD b/PKGBUILD
index b06671585eb9..e89cfd6b33f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,37 @@
-# Maintainer: sh0 <mee@sh0.org>
+# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+# Contributor: sh0 <mee@sh0.org>
pkgname=pdsh-genders
-pkgver=2.22
+pkgver=2.29
pkgrel=1
-pkgdesc='A high-performance, parallel remote shell utility'
-url='https://computing.llnl.gov/linux/pdsh.html'
+pkgdesc='Parallel Distributed Shell'
+url='http://code.google.com/p/pdsh/'
arch=('i686' 'x86_64')
license=('GPL')
depends=('glibc' 'openssh' 'readline' 'genders')
optdepends=('perl: required by the dshbak utility')
options=('libtool')
-source=("http://downloads.sourceforge.net/pdsh/pdsh-${pkgver}.tar.bz2")
+source=("http://pdsh.googlecode.com/files/pdsh-${pkgver}.tar.bz2")
conflicts=('pdsh')
-md5sums=('151b7a67079e88da0309a5c60432f4a9')
+provides=('pdsh')
+md5sums=('e3512d03e491de6f1a735ab0ff702108')
build() {
cd "${srcdir}/pdsh-${pkgver}"
- ./configure --prefix=/usr --mandir=/usr/share/man \
- --without-rsh \
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-ltdl-install \
--with-ssh \
- --without-machines \
- --without-dshgroups \
- --without-netgroup \
- --with-genders \
- --with-readline || return 1
- make || return 1
+ --with-genders \
+ --with-readline
+ make
}
package() {
cd "${srcdir}/pdsh-${pkgver}"
- make DESTDIR="${pkgdir}/" install || return 1
- rm -fr "${pkgdir}/usr/sbin"
+ make DESTDIR="${pkgdir}/" install
+ rmdir "${pkgdir}/usr/sbin"
}
# vim:set ts=2 sw=2 et: