summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpike2020-07-30 20:17:13 -0700
committerSpike2020-07-30 20:17:13 -0700
commitd783ed8366290d9d9e506803536ffb2afb691dfb (patch)
tree4e5b0eebac23ccd873de088bea4d9d9d45265d84
parent13e66e065fa74819d8d30e581c6194b1b863e94c (diff)
downloadaur-d783ed8366290d9d9e506803536ffb2afb691dfb.tar.gz
Moved to Gitlab
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD75
-rw-r--r--peafox.desktop15
-rw-r--r--peafox.pngbin0 -> 27005 bytes
-rw-r--r--peafox.sh2
5 files changed, 92 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6510641a317..ef0a925a5088 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = peafox
pkgdesc = Firefox fork hardened by default and without the telemetry.
- pkgver = 79.0a1
+ pkgver = 79.0.1
pkgrel = 0.2
url = https://github.com/peacockweb/peafox
- arch = i686
arch = x86_64
license = MPL
license = GPL
@@ -12,16 +11,22 @@ pkgbase = peafox
depends = gtk3
depends = libxt
depends = nss
- depends = mime-types
- optdepends = pulseaudio: audio support
- optdepends = ffmpeg: h.264 video
- optdepends = hunspell: spell checking
- optdepends = hyphen: hyphenation
- optdepends = libnotify: notification integration
- optdepends = networkmanager: location detection via available WiFi networks
- optdepends = speech-dispatcher: text-to-speech
- noextract = $pkgname_$pkgver.deb
- source = https://github.com/peacockweb/peafox/releases/download/v0.2/peafox_79.0a1.deb
+ optdepends = ffmpeg: H264/AAC/MP3 decoding
+ optdepends = hunspell: Spell checking
+ optdepends = hyphen: Hyphenation
+ optdepends = libnotify: Notification integration
+ optdepends = networkmanager: Location detection via available WiFi networks
+ optdepends = pulseaudio: Sound
+ optdepends = upower: Battery API
+ provides = peafox=79.0.1
+ conflicts = peafox
+ source = https://gitlab.com/spikecodes/peafox/uploads/2fc539675e0fd2a1e53c26e0ae042b2f/peafox-79.0.1.tar.bz2
+ source = peafox.desktop
+ source = peafox.png
+ source = peafox.sh
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = peafox
diff --git a/PKGBUILD b/PKGBUILD
index 1b1f2018e189..8b6b3d91d419 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,65 @@
# Maintainer: spikecodes <19519553+spikecodes@users.noreply.github.com>
pkgname=peafox
-pkgver=79.0a1
+pkgver=79.0.1
pkgrel=0.2
+upload_hash="2fc539675e0fd2a1e53c26e0ae042b2f"
pkgdesc="Firefox fork hardened by default and without the telemetry."
-arch=(i686 x86_64)
+arch=('x86_64')
url="https://github.com/peacockweb/peafox"
-license=(MPL GPL LGPL)
-depends=(dbus-glib gtk3 libxt nss mime-types)
-optdepends=('pulseaudio: audio support'
- 'ffmpeg: h.264 video'
- 'hunspell: spell checking'
- 'hyphen: hyphenation'
- 'libnotify: notification integration'
- 'networkmanager: location detection via available WiFi networks'
- 'speech-dispatcher: text-to-speech')
-source=("https://github.com/peacockweb/peafox/releases/download/v"$pkgrel"/"$pkgname"_"$pkgver".deb")
-noextract=('$pkgname_$pkgver.deb')
-md5sums=('SKIP')
+license=('MPL' 'GPL' 'LGPL')
+depends=('dbus-glib' 'gtk3' 'libxt' 'nss')
+optdepends=('ffmpeg: H264/AAC/MP3 decoding'
+ 'hunspell: Spell checking'
+ 'hyphen: Hyphenation'
+ 'libnotify: Notification integration'
+ 'networkmanager: Location detection via available WiFi networks'
+ 'pulseaudio: Sound'
+ 'upower: Battery API')
+provides=("peafox=$pkgver")
+conflicts=('peafox')
+source=("https://gitlab.com/spikecodes/peafox/uploads/$upload_hash/$pkgname-$pkgver.tar.bz2"
+ "peafox.desktop"
+ "peafox.png"
+ "peafox.sh")
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
package() {
- ar -xvf "$pkgname"_"$pkgver".deb
- tar -xvf "$srcdir"/data.tar.xz -C "$pkgdir"
-}
+ # Create directories
+ msg2 "Creating directory structure..."
+ mkdir -p "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/share
+ mkdir -p "$pkgdir"/usr/share/applications
+
+ msg2 "Moving files in place..."
+ # Install
+ cp -r peafox/ "$pkgdir"/usr/share/$pkgname
+
+ msg2 "Creating executable..."
+ # Launchers
+ install -m755 $pkgname.sh "$pkgdir"/usr/bin/$pkgname
+ # ln -s $pkgname "$pkgdir"/usr/bin/$pkgname # compatibility
+# ln -sf firefox "$pkgdir"/usr/share/$pkgname/firefox-bin
+
+ msg2 "Adding to application list..."
+ # Desktops
+ install -m644 *.desktop "$pkgdir"/usr/share/applications/
+
+ msg2 "Installing icons..."
+ # Icons
+ for i in 16x16 32x32 48x48 64x64 128x128; do
+ install -d "$pkgdir"/usr/share/icons/hicolor/$i/apps/
+ ln -s /usr/share/$pkgname/browser/chrome/icons/default/default${i/x*}.png \
+ "$pkgdir"/usr/share/icons/hicolor/$i/apps/$pkgname.png
+ done
+
+ # Use system-provided dictionaries
+ # rm -r "$pkgdir"/usr/share/$pkgname/dictionaries
+ # ln -Ts /usr/share/hunspell "$pkgdir"/usr/share/$pkgname/dictionaries
+ # ln -Ts /usr/share/hyphen "$pkgdir"/usr/share/$pkgname/hyphenation
+
+ # Use system certificates
+ # ln -sf /usr/lib/libnssckbi.so "$pkgdir"/usr/share/$pkgname/libnssckbi.so
+} \ No newline at end of file
diff --git a/peafox.desktop b/peafox.desktop
new file mode 100644
index 000000000000..2b8500f0e51d
--- /dev/null
+++ b/peafox.desktop
@@ -0,0 +1,15 @@
+[Desktop Entry]
+Name=Peafox
+GenericName=Peafox
+Comment=Firefox fork hardened by default and without the telemetry.
+Version=1.0
+
+Exec=peafox %u
+Icon=peafox
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+MimeType=text/html;text/xml;application/xhtml+xml;x-scheme-handler/http;x-scheme-handler/https;application/x-xpinstall;application/pdf;application/json;
+StartupNotify=true
+StartupWMClass=firefox
+Categories=Network;WebBrowser; \ No newline at end of file
diff --git a/peafox.png b/peafox.png
new file mode 100644
index 000000000000..34b5cabbcc82
--- /dev/null
+++ b/peafox.png
Binary files differ
diff --git a/peafox.sh b/peafox.sh
new file mode 100644
index 000000000000..96724c7b9941
--- /dev/null
+++ b/peafox.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/share/peafox/firefox --class "Peafox" --name "Peafox" "$@" \ No newline at end of file