summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDr-Noob2021-01-09 22:58:18 +0100
committerDr-Noob2021-01-09 22:58:18 +0100
commit64bf65a2d18370fd35a5eedf6225ca4e19b6a455 (patch)
tree40f273d0db7b6b6001b66e7d832fdeaa626f243d
parent51076cae084fc9edff547cff12b51cd77a46b492 (diff)
downloadaur-64bf65a2d18370fd35a5eedf6225ca4e19b6a455.tar.gz
Fix errors as suggested by FabioLolix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed878792c705..00937bf94fc2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = peakperf-git
pkgdesc = Benchmark to achieve peak performance on x86_64 CPUs
- pkgver = 1.0
+ pkgver = v1.0.r0.g3a5207a
pkgrel = 1
url = https://github.com/Dr-Noob/peakperf
arch = x86_64
license = MIT
makedepends = git
+ makedepends = make
depends = glibc
depends = gcc-libs
- depends = make
source = git+https://github.com/Dr-Noob/peakperf
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b8fabfe0e522..f437da6b310e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
# Maintainer: Dr-Noob <peibolms at gmail dot com>
_name=peakperf
pkgname="$_name-git"
-pkgver=1.0
+pkgver=v1.0.r0.g3a5207a
pkgrel=1
pkgdesc="Benchmark to achieve peak performance on x86_64 CPUs"
arch=('x86_64')
url="https://github.com/Dr-Noob/peakperf"
license=('MIT')
-depends=('glibc' 'gcc-libs' 'make')
-makedepends=('git')
+depends=('glibc' 'gcc-libs')
+makedepends=('git' 'make')
source=("git+https://github.com/Dr-Noob/peakperf")
md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/$_name"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd "$srcdir/$_name"
make