summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-07-14 20:49:47 -0400
committerJames An2015-07-14 20:49:47 -0400
commit5cd7269004b24e251e76988e144741081816d387 (patch)
tree877a16ac478a926bb3e253d3a87bfad944a2a933
downloadaur-5cd7269004b24e251e76988e144741081816d387.tar.gz
Initial commit.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore27
-rw-r--r--PKGBUILD26
-rw-r--r--channel.xml16
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0db1f3870195
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pear-channel-phpseclib
+ pkgdesc = PHP Secure Communications Library PEAR channel
+ pkgver = 1
+ pkgrel = 1
+ url = http://phpseclib.sourceforge.net/
+ arch = any
+ license = MIT
+ depends = php-pear
+ options = !strip
+ source = http://phpseclib.sourceforge.net/channel.xml
+ md5sums = f10b822379303e0b2ebd4072ae2ea7e6
+
+pkgname = pear-channel-phpseclib
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..43316bc3c124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5efc2c99a2a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+#Maintainer: James An <james@jamesan.ca>
+
+pkgname=pear-channel-phpseclib
+pkgver=1
+pkgrel=1
+pkgdesc='PHP Secure Communications Library PEAR channel'
+arch=('any')
+url="http://phpseclib.sourceforge.net/"
+license=('MIT')
+depends=('php-pear')
+options=('!strip')
+source=(http://phpseclib.sourceforge.net/channel.xml)
+md5sums=('f10b822379303e0b2ebd4072ae2ea7e6')
+
+package() {
+ local _PEARDIR="${pkgdir}/usr/share/pear"
+ local _PEAROPTS="-D php_dir=${_PEARDIR} -D doc_dir=${_PEARDIR}/doc"
+ local _PEAROPTS="${_PEAROPTS} -D test_dir=${_PEARDIR}/test"
+ local _PEAROPTS="${_PEAROPTS} -D data_dir=${_PEARDIR}/data"
+ pear ${_PEAROPTS} channel-add channel.xml
+ rm ${_PEARDIR}/{.depdb*,.filemap,.lock}
+ rm -r ${_PEARDIR}/.channels/{__uri.reg,*.php.net*}
+ rm ${_PEARDIR}/.channels/.alias/{pear.txt,pecl.txt,phpdocs.txt}
+ rm -r ${_PEARDIR}/.registry/{.channel.__uri,.channel.*.php.net}
+}
+
diff --git a/channel.xml b/channel.xml
new file mode 100644
index 000000000000..462911b094fd
--- /dev/null
+++ b/channel.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
+ <name>phpseclib.sourceforge.net</name>
+ <summary>PHP Secure Communications Library PEAR channel</summary>
+ <suggestedalias>phpseclib</suggestedalias>
+ <servers>
+ <primary>
+ <rest>
+ <baseurl type="REST1.0">http://phpseclib.sourceforge.net//rest/</baseurl>
+ <baseurl type="REST1.1">http://phpseclib.sourceforge.net//rest/</baseurl>
+ <baseurl type="REST1.2">http://phpseclib.sourceforge.net//rest/</baseurl>
+ <baseurl type="REST1.3">http://phpseclib.sourceforge.net//rest/</baseurl>
+ </rest>
+ </primary>
+ </servers>
+</channel> \ No newline at end of file