summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-09 15:09:50 +0800
committerzxp198210052024-04-09 15:09:50 +0800
commit27c981e07201bd429b4c459e02924b1f44243787 (patch)
treedac56269b1d99c291e1e47271727d87485b383bc
downloadaur-27c981e07201bd429b4c459e02924b1f44243787.tar.gz
update to 1.3.15
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD47
-rw-r--r--pear-rec.sh16
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..049f859cbe12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pear-rec-bin
+ pkgdesc = An open-source, cross-platform terminal for seamless workflows
+ pkgver = 1.3.15
+ pkgrel = 1
+ url = https://027xiguapi.github.io/pear-rec/
+ arch = x86_64
+ license = Apache-2.0
+ makedepends = fuse2
+ depends = electron29
+ provides = pear-rec=1.3.15
+ conflicts = pear-rec
+ source = pear-rec-1.3.15.AppImage::https://github.com/027xiguapi/pear-rec/releases/download/v1.3.15/pear-rec-Linux-1.3.15.AppImage
+ source = pear-rec.sh
+ sha256sums = db2241b3dcb16162da72ee02be22e10e5b0281a3726669cf559e4860ba0eb5c5
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
+
+pkgname = pear-rec-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a72f8d3173c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=pear-rec-bin
+_pkgname="@${pkgname%-bin}desktop"
+pkgver=1.3.15
+_electronversion=29
+pkgrel=1
+pkgdesc="An open-source, cross-platform terminal for seamless workflows"
+arch=(
+ 'x86_64'
+)
+url="https://027xiguapi.github.io/pear-rec/"
+_ghurl="https://github.com/027xiguapi/pear-rec"
+license=('Apache-2.0')
+conflicts=("${pkgname%-bin}")
+provides=("${pkgname%-bin}=${pkgver}")
+depends=(
+ "electron${_electronversion}"
+)
+makedepends=(
+ 'fuse2'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-Linux-${pkgver}.AppImage"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('db2241b3dcb16162da72ee02be22e10e5b0281a3726669cf559e4860ba0eb5c5'
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+build() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@runname@|app.asar|g" \
+ -e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g;s|Video;|Video;AudioVideo;|g" -i "${srcdir}/squashfs-root/${_pkgname}.desktop"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
+ for _icons in 16x16 24x24 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024;do
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${_pkgname}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png"
+ done
+ install -Dm644 "${srcdir}/squashfs-root/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+} \ No newline at end of file
diff --git a/pear-rec.sh b/pear-rec.sh
new file mode 100644
index 000000000000..7ddcaab8d734
--- /dev/null
+++ b/pear-rec.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+set -e
+_APPDIR="/usr/lib/@appname@"
+_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
+export NODE_ENV=production
+cd "${_APPDIR}"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
+else
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file