summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Squillace2016-04-30 19:05:02 +0100
committerFilippo Squillace2016-04-30 19:05:02 +0100
commit5ff194ff6fe21491aa30def2a68c527cae128074 (patch)
tree8f63692421a54d14cf9296e9d1c4f220237ed82f
parent925fb1aa21df09bc11fa0fcb9567e533c5369e45 (diff)
downloadaur-5ff194ff6fe21491aa30def2a68c527cae128074.tar.gz
Use symlinks instead of chaning the PATH variable
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD9
3 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94a87271068b..ad56c1207d8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pearl-git
pkgdesc = Package manager for dotfiles, plugins, programs and any form of code accessible via git. Allow to easily share and sync packages across systems and have them ready to work out of the box.
- pkgver = r71.2915577
+ pkgver = r75.6458dc7
pkgrel = 1
url = https://github.com/pearl-core/pearl
install = pearl.install
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1377554ebea6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.swp
diff --git a/PKGBUILD b/PKGBUILD
index 878b5cfa1031..9627c4f17d7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# https://wiki.archlinux.org/index.php/Creating_packages
pkgname=pearl-git
-pkgver=r71.2915577
+pkgver=r75.6458dc7
pkgrel=1
pkgdesc="Package manager for dotfiles, plugins, programs and any form of code accessible via git. Allow to easily share and sync packages across systems and have them ready to work out of the box."
arch=('any')
@@ -49,11 +49,8 @@ package() {
mkdir -p "${pkgdir}/opt/"
cp -R "${srcdir}/${pkgname%-git}" "${pkgdir}/opt/${pkgname%-git}"
- mkdir -p "${pkgdir}/etc/profile.d/"
- echo "export PATH=\$PATH:/opt/${pkgname%-git}/bin" > "${pkgdir}/etc/profile.d/${pkgname%-git}"
- chmod +x "${pkgdir}/etc/profile.d/${pkgname%-git}"
- echo "set -x PATH \$PATH /opt/${pkgname%-git}/bin" > "${pkgdir}/etc/profile.d/${pkgname%-git}.fish"
- chmod +x "${pkgdir}/etc/profile.d/${pkgname%-git}.fish"
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s ../../opt/${pkgname%-git}/bin/${pkgname%-git} ${pkgdir}/usr/bin/${pkgname%-git}
}
# vim:set ts=2 sw=2 et: