summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Squillace2024-03-21 23:31:15 +0100
committerFilippo Squillace2024-03-21 23:32:13 +0100
commitbd858a14bf78be578ea8e76a69234fdaef15e291 (patch)
tree67eb9216c0049827abd8e972a864b41077b554d8
parent0ad4d3696f8fe92e3dd721ca410228d940664865 (diff)
downloadaur-bd858a14bf78be578ea8e76a69234fdaef15e291.tar.gz
fix: install buava submodule
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 820d5c6336b8..3d837816cf58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pearl-git
pkgdesc = Package manager for dotfiles, plugins, programs and any form of code accessible via git. Allow to easily share and sync packages across systems and have them ready to work out of the box.
- pkgver = r134.e8b4482
+ pkgver = r140.e504230
pkgrel = 1
url = https://github.com/pearl-core/pearl
install = pearl.install
@@ -16,6 +16,8 @@ pkgbase = pearl-git
provides = pearl
conflicts = pearl
source = pearl::git+https://github.com/pearl-core/pearl.git#branch=master
+ source = git+https://github.com/fsquillace/buava#branch=master
+ md5sums = SKIP
md5sums = SKIP
pkgname = pearl-git
diff --git a/PKGBUILD b/PKGBUILD
index f748e14e0079..bec979b76180 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# https://wiki.archlinux.org/title/Python_package_guidelines
pkgname=pearl-git
-pkgver=r134.e8b4482
+pkgver=r140.e504230
pkgrel=1
pkgdesc="Package manager for dotfiles, plugins, programs and any form of code accessible via git. Allow to easily share and sync packages across systems and have them ready to work out of the box."
arch=('any')
@@ -23,9 +23,16 @@ options=()
install=${pkgname%-git}.install
# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
# a description of each element in the source array.
-source=('pearl::git+https://github.com/pearl-core/pearl.git#branch=master')
+source=('pearl::git+https://github.com/pearl-core/pearl.git#branch=master' 'git+https://github.com/fsquillace/buava#branch=master')
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP' 'SKIP')
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ git submodule init
+ git config submodule.src/pearllib/static/buava.url "$srcdir/buava"
+ git -c protocol.file.allow=always submodule update
+}
pkgver() {