summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Squillace2020-01-11 16:58:24 +0100
committerFilippo Squillace2020-01-11 16:58:24 +0100
commitf143a208c2037d4f69af917d8f8019ecd9d208ed (patch)
treed9b5b78c6ff20e775f582eec2fe31a10ad628b5e
parentc01e10ac8d44b477d85d40be262227860140be3c (diff)
downloadaur-f143a208c2037d4f69af917d8f8019ecd9d208ed.tar.gz
Update to the newest Pearl version 2.0
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
-rw-r--r--pearl.install2
3 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad56c1207d8f..16687a3daec0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pearl-git
pkgdesc = Package manager for dotfiles, plugins, programs and any form of code accessible via git. Allow to easily share and sync packages across systems and have them ready to work out of the box.
- pkgver = r75.6458dc7
+ pkgver = r35.44fcca3
pkgrel = 1
url = https://github.com/pearl-core/pearl
install = pearl.install
@@ -8,6 +8,7 @@ pkgbase = pearl-git
license = GPL
makedepends = git
depends = git
+ depends = python
provides = pearl
conflicts = pearl
source = pearl::git+https://github.com/pearl-core/pearl.git#branch=master
diff --git a/PKGBUILD b/PKGBUILD
index 9627c4f17d7e..57e7eef1a876 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
# https://wiki.archlinux.org/index.php/Creating_packages
pkgname=pearl-git
-pkgver=r75.6458dc7
+pkgver=r35.44fcca3
pkgrel=1
pkgdesc="Package manager for dotfiles, plugins, programs and any form of code accessible via git. Allow to easily share and sync packages across systems and have them ready to work out of the box."
arch=('any')
url="https://github.com/pearl-core/pearl"
license=('GPL')
groups=()
-depends=('git')
+depends=('git' 'python')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -43,14 +43,19 @@ pkgver() {
}
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ /usr/bin/python setup.py build
+}
+
package() {
cd "$srcdir/${pkgname%-git}"
- mkdir -p "${pkgdir}/opt/"
- cp -R "${srcdir}/${pkgname%-git}" "${pkgdir}/opt/${pkgname%-git}"
+ #make dist
+ #/usr/bin/pip install --install-option="--prefix=${pkgdir}" dist/*.whl
+ #/usr/bin/pip install --target=${pkgdir} dist/*.whl
- mkdir -p "${pkgdir}/usr/bin"
- ln -s ../../opt/${pkgname%-git}/bin/${pkgname%-git} ${pkgdir}/usr/bin/${pkgname%-git}
+ /usr/bin/python setup.py install --root=${pkgdir} --optimize=1
}
# vim:set ts=2 sw=2 et:
diff --git a/pearl.install b/pearl.install
index aa17be4a27ea..edd9054f98c4 100644
--- a/pearl.install
+++ b/pearl.install
@@ -1,5 +1,5 @@
_post(){
- pearl init
+ /usr/bin/pearl init
}
# arg 1: the new package version