summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshyam2023-09-03 19:28:24 +0530
committershyam2023-09-03 19:28:24 +0530
commiteae9ace234538ae479e742cf8cab90c170515711 (patch)
treeeab4fe8743a10f5133c8e91fc6224278a0742df7
downloadaur-eae9ace234538ae479e742cf8cab90c170515711.tar.gz
Privilege Escalation Awesome Scripts SUITE new generation for AUR
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD38
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e19b5b48181
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = peass-ng
+ pkgdesc = Privilege Escalation Awesome Scripts SUITE new generation
+ pkgver = 811c3654
+ pkgrel = 1
+ url = https://github.com/carlospolop/PEASS-ng
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = github-cli
+ source = git+https://github.com/carlospolop/PEASS-ng.git
+ sha512sums = SKIP
+
+pkgname = peass-ng
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19c63b40660d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+_base=PEASS-ng
+pkgname=peass-ng
+pkgver=811c3654
+_pkgver=20230903
+pkgrel=1
+pkgdesc="Privilege Escalation Awesome Scripts SUITE new generation"
+arch=(any)
+url="https://github.com/carlospolop/PEASS-ng"
+license=(MIT)
+source=("git+https://github.com/carlospolop/PEASS-ng.git")
+makedepends=('git' 'github-cli')
+sha512sums=(SKIP)
+
+pkgver() {
+ cd "${_base}"
+ git describe --tags | cut -d '-' -f 2
+}
+
+prepare() {
+ cd ${_base}
+ gh release download --pattern '*' -D release -R ${url} --clobber
+}
+
+package() {
+
+ cd ${_base}/release
+
+ # Install to /usr/share/peass-ng
+
+ ## Linux
+ find . -name "lin*" -printf "%f\n" -exec install -Dm644 {} "${pkgdir}/usr/share/${pkgname}/linux/{}" \;
+
+ ## Windows
+ find . -name "win*" -printf "%f\n" -exec install -Dm644 {} "${pkgdir}/usr/share/${pkgname}/windows/{}" \;
+
+ install -Dm 644 ../LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+