summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Conseil2015-06-13 00:17:20 +0200
committerSimon Conseil2015-06-13 00:17:20 +0200
commitbac596f67dec23c91aedfbc3f18db2ef57b29f15 (patch)
treeec863e3c2676425d036f571c2fd01f047c624d2b
downloadaur-bac596f67dec23c91aedfbc3f18db2ef57b29f15.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0c1d539c821
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = peat
+ pkgdesc = Repeat commands!
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/sjl/peat
+ arch = any
+ license = GPL3
+ depends = python2
+ source = https://github.com/sjl/peat/archive/v0.3.0.tar.gz
+ md5sums = c8826f667d69e274e476966806adaf30
+
+pkgname = peat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a311cc66a6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Simon Conseil <contact+aur at saimon dot org>
+pkgname=peat
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Repeat commands!"
+arch=('any')
+url="https://github.com/sjl/peat"
+license=('GPL3')
+depends=('python2')
+source=("https://github.com/sjl/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('c8826f667d69e274e476966806adaf30')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" peat
+
+ mkdir -p "$pkgdir/usr/bin"
+ install -m755 "$srcdir/$pkgname-$pkgver"/peat "$pkgdir"/usr/bin/peat
+}