summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-12-16 23:42:09 +0100
committerbegin-theadventure2023-12-16 23:42:09 +0100
commitd48a1a42709ba770add3a2aa1c27c2879974c450 (patch)
treee6cc13afc8397cfb824f13503982563ee0a705cc
parent669db335914e8c0683e59770af351d9224b6689b (diff)
downloadaur-d48a1a42709ba770add3a2aa1c27c2879974c450.tar.gz
9.6.0; clean up
-rw-r--r--.SRCINFO18
-rw-r--r--.editorconfig19
-rw-r--r--PKGBUILD64
-rwxr-xr-xprepare_pkg.sh7
4 files changed, 37 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a01b3cdb055a..4f64f4116df9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,21 @@
pkgbase = peazip-qt-bin
- pkgdesc = PeaZip file manager and archiver (Qt5)
- pkgver = 9.5.0
+ pkgdesc = PeaZip file manager and archiver (Qt5, binary release)
+ pkgver = 9.6.0
pkgrel = 1
url = https://github.com/peazip/PeaZip
arch = x86_64
license = LGPL3
depends = qt5pas
- optdepends = 7-zip: File archiver with a high compression ratio
- optdepends = quad: High-performance file compressor that utilizes an advanced LZ-based compression algorithm
optdepends = arc: Arc file archiver and compressor
- optdepends = zpaq: Programmable file compressor, library and utilities
optdepends = paq8o: PAQ8 series of archivers, resurrected by new maintainers
+ optdepends = quad: High-performance file compressor that utilizes an advanced LZ-based compression algorithm
optdepends = upx: Extendable, high-performance executable packer for several executable formats
+ optdepends = zpaq: Programmable file compressor, library and utilities
+ optdepends = 7-zip: File archiver with a high compression ratio
provides = peazip
- conflicts = peazip-gtk2-bin
- conflicts = peazip-qt5
- conflicts = peazip-qt5-bin
+ conflicts = peazip
options = !emptydirs
- source = https://github.com/peazip/PeaZip/releases/download/9.5.0/peazip-9.5.0.LINUX.Qt5-1.x86_64.rpm
- sha256sums = 82aea1a3cc213373ee5699b4c3d2035259f1c6161f0887b74b6ee6ba3263944e
+ source = https://github.com/peazip/PeaZip/releases/download/9.6.0/peazip-9.6.0.LINUX.Qt5-1.x86_64.rpm
+ sha256sums = b22c0ef4d3539cc96c39e880b26954f6c674f23e76dc021151a1e25c268ba40e
pkgname = peazip-qt-bin
diff --git a/.editorconfig b/.editorconfig
deleted file mode 100644
index 160ce78ad85e..000000000000
--- a/.editorconfig
+++ /dev/null
@@ -1,19 +0,0 @@
-root = true
-
-[*]
-charset = utf-8
-insert_final_newline = true
-trim_trailing_whitespace = true
-indent_style = tab
-indent_size = 4
-
-[{*.sh, PKGBUILD}]
-end_of_line = lf
-indent_size = 2
-indent_style = space
-tab_width = 2
-
-[*.txt]
-end_of_line = lf
-indent_size = 2
-indent_style = space
diff --git a/PKGBUILD b/PKGBUILD
index eb4824139c23..5ff662941b29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,51 +9,45 @@
# Contributor: Jamesjon <universales@protonmail.com>
pkgname=peazip-qt-bin
-pkgver=9.5.0
+pkgver=9.6.0
pkgrel=1
-pkgdesc='PeaZip file manager and archiver (Qt5)'
+pkgdesc='PeaZip file manager and archiver (Qt5, binary release)'
arch=('x86_64')
url='https://github.com/peazip/PeaZip'
license=('LGPL3')
depends=('qt5pas')
options=('!emptydirs')
-optdepends=('7-zip: File archiver with a high compression ratio'
- 'quad: High-performance file compressor that utilizes an advanced LZ-based compression algorithm'
- 'arc: Arc file archiver and compressor'
- 'zpaq: Programmable file compressor, library and utilities'
- 'paq8o: PAQ8 series of archivers, resurrected by new maintainers'
- 'upx: Extendable, high-performance executable packer for several executable formats')
+optdepends=('arc: Arc file archiver and compressor'
+ 'paq8o: PAQ8 series of archivers, resurrected by new maintainers'
+ 'quad: High-performance file compressor that utilizes an advanced LZ-based compression algorithm'
+ 'upx: Extendable, high-performance executable packer for several executable formats'
+ 'zpaq: Programmable file compressor, library and utilities'
+ '7-zip: File archiver with a high compression ratio')
provides=('peazip')
-conflicts=('peazip-gtk2-bin' 'peazip-qt5' 'peazip-qt5-bin')
-source=("$url/releases/download/${pkgver}/peazip-${pkgver}.LINUX.Qt5-1.${CARCH}.rpm")
-sha256sums=('82aea1a3cc213373ee5699b4c3d2035259f1c6161f0887b74b6ee6ba3263944e')
+conflicts=('peazip')
+source=("$url/releases/download/$pkgver/peazip-$pkgver.LINUX.Qt5-1.x86_64.rpm")
+sha256sums=('b22c0ef4d3539cc96c39e880b26954f6c674f23e76dc021151a1e25c268ba40e')
prepare() {
- rm -r usr/share/peazip/batch/{Windows,'macOS service menus',bat}
- rm -r usr/share/peazip/batch/freedesktop_integration/KDE-servicemenus/{KDE3*,KDE4*}
- rm usr/share/peazip/icons/peazip_seven.icl
- rm -r usr/share/peazip/lang-wincontext
- rm usr/share/peazip/readme/readme_{Windows,macOS}.txt
- rm usr/lib/peazip/res/bin/7z/7z.sfx
- chmod -x usr/lib/peazip/res/bin/7z/Codecs/*.so
+ rm -r usr/share/peazip/batch/{Windows,'macOS service menus',bat}
+ rm -r usr/share/peazip/batch/freedesktop_integration/KDE-servicemenus/{KDE3*,KDE4*}
+ rm usr/share/peazip/icons/peazip_seven.icl
+ rm -r usr/share/peazip/lang-wincontext
+ rm usr/share/peazip/readme/readme_{Windows,macOS}.txt
+ rm usr/lib/peazip/res/bin/7z/7z.sfx
+ chmod -x usr/lib/peazip/res/bin/7z/Codecs/*.so
}
package() {
- local usr_share_peazip='usr/share/peazip'
-
- install -dm755 "${pkgdir}/usr/"{bin,lib/peazip,share/{doc/peazip,peazip,licenses/peazip/}}
-
- cp -a usr/bin/peazip "${pkgdir}/usr/bin/"
-
- cp -ar usr/lib/peazip/{peazip,pea,res} -t "${pkgdir}/usr/lib/peazip/"
-
- mv "${usr_share_peazip}"/copying/* "${pkgdir}/usr/share/licenses/peazip"
-
- mv "${usr_share_peazip}/peazip_help.pdf" "${pkgdir}/usr/share/doc/peazip/help.pdf"
-
- mv "${usr_share_peazip}/readme/readme_Linux.txt" "${pkgdir}/usr/share/doc/peazip/readme.txt"
- rm -r "${usr_share_peazip}/readme/"
-
- cp -ar "${usr_share_peazip}" -t "${pkgdir}/usr/share"
- cp -ar usr/share/{pixmaps,applications} -t "${pkgdir}/usr/share/"
+ mkdir -p "$pkgdir/usr/"{bin,lib/peazip,share/{doc/peazip,peazip,licenses/peazip}}
+ cd usr
+ mv bin/peazip "$pkgdir/usr/bin"
+ mv lib/peazip/{peazip,pea,res} "$pkgdir/usr/lib/peazip"
+ cd share
+ mv peazip/peazip_help.pdf "$pkgdir/usr/share/doc"
+ mv peazip/copying/* "$pkgdir/usr/share/licenses/peazip"
+ mv peazip/readme/readme_Linux.txt "$pkgdir/usr/share/doc/peazip/readme.txt"
+ rm -r "peazip/readme"
+ mv peazip "$pkgdir/usr/share"
+ mv pixmaps applications "$pkgdir/usr/share"
}
diff --git a/prepare_pkg.sh b/prepare_pkg.sh
deleted file mode 100755
index 95c06f7eae7f..000000000000
--- a/prepare_pkg.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/usr/bin/env bash
-
-updpkgsums
-
-makepkg --printsrcinfo > .SRCINFO
-
-# makepkg --install