summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Svyatski2021-11-21 00:03:40 +0300
committerVladimir Svyatski2021-11-21 00:12:49 +0300
commitd75d2374f89b5c1a6c85433534bab1fdd06602f8 (patch)
tree01a40aeede7f3e4f5487641bbe83c4e09611c116
parentfd89b6fd7bab853d0a8cf4d3a36f149a8243b2e4 (diff)
downloadaur-d75d2374f89b5c1a6c85433534bab1fdd06602f8.tar.gz
Updating to 8.3. Adding changelog.
-rw-r--r--.SRCINFO9
-rw-r--r--.editorconfig14
-rw-r--r--.gitattributes6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD65
-rw-r--r--changelog.txt34
6 files changed, 95 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2597342d04fd..99283fdc4e2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = peazip-qt-bin
pkgdesc = PeaZip file manager and archiver (Qt5)
- pkgver = 8.2.0
- pkgrel = 2
+ pkgver = 8.3.0
+ pkgrel = 1
url = https://peazip.github.io
+ changelog = changelog.txt
arch = x86_64
license = LGPL3
depends = qt5pas
@@ -17,7 +18,7 @@ pkgbase = peazip-qt-bin
conflicts = peazip-qt5
conflicts = peazip-qt5-bin
options = !emptydirs
- source = https://github.com/peazip/PeaZip/releases/download/8.2.0/peazip-8.2.0.LINUX.Qt5-1.x86_64.rpm
- sha256sums = d4b6e56eb7f12f8e7338e0ebeb749a9f61d9c1ca28577bde6a91f5190a0df020
+ source = https://github.com/peazip/PeaZip/releases/download/8.3.0/peazip-8.3.0.LINUX.Qt5-1.x86_64.rpm
+ sha256sums = d67bd88040d70f350360aff156e049143f091997f5afe0294eac70fb19cbca18
pkgname = peazip-qt-bin
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..77a5f5e84dd3
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,14 @@
+root = true
+
+[*]
+charset = utf-8
+insert_final_newline = true
+trim_trailing_whitespace = true
+indent_style = tab
+indent_size = 4
+
+[{*.sh, PKGBUILD}]
+end_of_line = lf
+indent_size = 2
+indent_style = space
+tab_width = 2
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..f8624bf43586
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1,6 @@
+* text=auto
+
+PKGBUILD text eol=lf
+*.sh text eol=lf
+.SRCINFO text eol=lf
+changelog.txt text eol=lf
diff --git a/.gitignore b/.gitignore
index 15a13c62e478..eea069ea84f4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,6 @@
-.idea
pkg
src
*.rpm
*.pkg.tar.*
.fuse_*
+.idea
diff --git a/PKGBUILD b/PKGBUILD
index 33a00a68a0ab..f6479c9889af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
# Contributor: Jamesjon <universales@protonmail.com>
pkgname=peazip-qt-bin
-pkgver=8.2.0
-pkgrel=2
+pkgver=8.3.0
+pkgrel=1
pkgdesc="PeaZip file manager and archiver (Qt5)"
arch=('x86_64')
url='https://peazip.github.io'
@@ -24,37 +24,42 @@ optdepends=('p7zip: Command-line file archiver with high compression ratio'
provides=('peazip')
conflicts=('peazip-gtk2-bin' 'peazip-qt5' 'peazip-qt5-bin')
source=("https://github.com/peazip/PeaZip/releases/download/${pkgver}/peazip-${pkgver}.LINUX.Qt5-1.x86_64.rpm")
-sha256sums=('d4b6e56eb7f12f8e7338e0ebeb749a9f61d9c1ca28577bde6a91f5190a0df020')
+sha256sums=('d67bd88040d70f350360aff156e049143f091997f5afe0294eac70fb19cbca18')
+changelog=changelog.txt
-package() {
- # preparing /usr/**/* files for installation
- mkdir "${pkgdir}/usr"
- cp -aR usr/bin/ "${pkgdir}/usr"
- cp -aR usr/share/ "${pkgdir}/usr"
+prepare() {
+ rm -r usr/lib/.build-id
+ rm usr/lib/libQt5Pas.so.1
+ rm usr/lib/peazip/libQt5Pas.so.1
+ # 7z.sfx is a Windows executable
+ rm usr/lib/peazip/res/bin/7z/7z.sfx
+
+ local sharedUsr=usr/share
+ local sharedPeaZip="${sharedUsr}/peazip"
+ rm "${sharedPeaZip}/readme/readme_Windows.txt"
+ rm "${sharedPeaZip}/batch/"*.bat
+ rm -r "${sharedPeaZip}/batch/SendTo"
+ rm -r "${sharedPeaZip}/batch/freedesktop_integration/KDE-servicemenus/KDE3-konqueror"
- # preparing /opt/peazip/* files for installation
- local peazipDest="${pkgdir}/opt/peazip"
- mkdir -p "${peazipDest}"
- install -m 644 opt/peazip/*.txt "${peazipDest}" # copying *.txt files and removing executable flag from them
- cp opt/peazip/*.pdf "${peazipDest}/"
- cp opt/peazip/peazip "${peazipDest}/"
-
- # preparing /opt/peazip/res/**/* files for installation
- mkdir "${peazipDest}/res"
- cd opt/peazip/res
- install pea rnd "${peazipDest}/res"
- install -m 644 altconf.txt "${peazipDest}/res" # copying altconf.txt and removing executable flag from it
- for resSubDir in */; do # looping through all directories in "res" except "batch"
- if [ "${resSubDir}" = "batch/" ]; then continue; fi
- cp -aR ${resSubDir} "${peazipDest}/res"
- if [ -f "${peazipDest}/res/${resSubDir}note.txt" ]; then
- chmod 644 "${peazipDest}/res/${resSubDir}note.txt" # removing executable flag from note.txt
+ # setting correct permissions
+ chmod 755 usr && chmod 755 usr/bin
+ chmod 755 usr/lib && chmod 755 usr/lib/peazip
+ chmod 755 usr/lib/peazip/res && chmod -R 755 usr/lib/peazip/res/bin
+ chmod -x usr/lib/peazip/res/bin/7z/*.so
+ chmod -x usr/lib/peazip/res/bin/7z/Codecs/*.so
+ chmod 755 "${sharedUsr}"
+ for subDir in "${sharedUsr}"/*; do chmod 755 "${subDir}"; done
+ chmod 755 "${sharedUsr}/doc/peazip"
+ for subDir in "${sharedPeaZip}"/*; do
+ if [ -d "${subDir}" ]; then
+ chmod 755 $(find "${subDir}" -type d)
fi
done
+}
- # let's take care of "batch"
- mkdir "${peazipDest}/res/batch"
- cp batch/*.sh "${peazipDest}/res/batch"
- cp -aR batch/freedesktop_integration "${peazipDest}/res/batch"
- cd -
+package() {
+ mkdir "${pkgdir}/usr"
+ cp -aR usr/bin/ "${pkgdir}/usr"
+ cp -aR usr/lib/ "${pkgdir}/usr"
+ cp -aR usr/share/ "${pkgdir}/usr"
}
diff --git a/changelog.txt b/changelog.txt
new file mode 100644
index 000000000000..831fa1fb68b4
--- /dev/null
+++ b/changelog.txt
@@ -0,0 +1,34 @@
+* Wed Nov 17 2021 Vladimir Svyatski <vsvyatski@yandex.ru> - 8.3.0-1
+ PeaZip 8.3.0 adds Deflate and Deflate64 options for .7z format, improves theming,
+ command line usage, management of preferred checksum/hash algorithms list and
+ management of temporary work files.
+ The release is focused on improving the support for Linux, and to make easier to
+ port or package the application in environments, mandating a precise filesystem
+ hierarchy structure, separating architecture-dependent binary resources from other
+ types of resources, packaged with the application.
+ Full list of changes and fixes is available at https://peazip.github.io/changelog.html
+
+* Sat Sep 18 2021 Vladimir Svyatski <vsvyatski@yandex.ru> - 8.2.0-2
+ - Removed unnecessary Windows-related files.
+ - Corrected file permissions.
+
+* Sat Sep 18 2021 Vladimir Svyatski <vsvyatski@yandex.ru> - 8.2.0-1
+ PeaZip 8.2.0 is focused on improving the use from command line and scripts, and
+ introduces the (peazip)/res/batch folder, which contains sample scripts and system
+ integration files for both Linux and Windows (the SendTo and freedesktop_integration
+ folders are moved there).
+ The archive manager is now capable of optionally displaying compression/encryption
+ method and modified, created, accessed timestamps for each item in the archive, and
+ displaying the number of items, contained in each folder.
+ It is now possible to choose to keep extracted files even in the case errors occurred
+ during the extraction; working with spanned files was improved.
+ "Smart extraction" is now available as a default action to take at program's startup,
+ alongside "Open", "Open as archive", "Extract (full)", "Extract here".
+ This release also improves the user experience on Linux systems by improving the
+ automatic configuration of applications for the "open with" actions and by displaying
+ more system paths in the file manager.
+ The application is now installed in /opt/peazip.
+ The backend was updated to Brotli 1.0.9 (Linux).
+ A total of 225 file extensions can now be managed by PeaZip, with addition of .apkm,
+ .apks and .aab Android package formats, and of Lzip .lz (supported on Linux versions
+ only).