summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSiavash Askari Nasr2023-05-23 12:24:59 +0330
committerSiavash Askari Nasr2023-05-23 12:24:59 +0330
commite00a02ec1ac903d2ef128b759ac4a209825fd71e (patch)
treeaba7e19b7d12b86bfc5d560366975ea958fb84d2
parent8ebbdec1215355ec1e67f6747bf405ea7d198ddd (diff)
downloadaur-e00a02ec1ac903d2ef128b759ac4a209825fd71e.tar.gz
Update to version 9.2.0
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD86
-rw-r--r--changelog.txt10
-rwxr-xr-xprepare_pkg.sh7
-rw-r--r--update-srcinfo.sh5
6 files changed, 56 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c090ce7e81e..8c30bdc94371 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = peazip-qt-bin
pkgdesc = PeaZip file manager and archiver (Qt5)
- pkgver = 9.1.0
+ pkgver = 9.2.0
pkgrel = 1
url = https://peazip.github.io
changelog = changelog.txt
arch = x86_64
license = LGPL3
depends = qt5pas
- optdepends = p7zip: Command-line file archiver with high compression ratio
+ optdepends = 7-zip: File archiver with a high compression ratio
optdepends = quad: High-performance file compressor that utilizes an advanced LZ-based compression algorithm
optdepends = arc: Arc file archiver and compressor
optdepends = zpaq: Programmable file compressor, library and utilities
@@ -18,7 +18,7 @@ pkgbase = peazip-qt-bin
conflicts = peazip-qt5
conflicts = peazip-qt5-bin
options = !emptydirs
- source = https://github.com/peazip/PeaZip/releases/download/9.1.0/peazip-9.1.0.LINUX.Qt5-1.x86_64.rpm
- sha256sums = f2abd125f3f50c2f99e007f59940a2a17cd5a26f2b7b064a2dc579d58e92e880
+ source = https://github.com/peazip/PeaZip/releases/download/9.2.0/peazip-9.2.0.LINUX.Qt5-1.x86_64.rpm
+ sha256sums = c8ebcacdba92685fd1a769c74a7df224e5dee1c0c63d1f42450e380cf9b7f279
pkgname = peazip-qt-bin
diff --git a/.gitignore b/.gitignore
index eea069ea84f4..72e8ffc0db8a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1 @@
-pkg
-src
-*.rpm
-*.pkg.tar.*
-.fuse_*
-.idea
+*
diff --git a/PKGBUILD b/PKGBUILD
index ac8b81fd0741..b7e89443fef2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
-# Maintainer: Vladimir Svyatski <vsvyatski@yandex.ru>
-# Previous Maintainer: Dimitris Kiziridis <ragouel@outlook.com>
+# Maintainer: Siavash Askari Nasr <ciavash@proton.me>
+# Previous Maintainer: Vladimir Svyatski <vsvyatski@yandex.ru>
+# Contributor: Dimitris Kiziridis <ragouel@outlook.com>
# Contributor: EatMyVenom <eat.my.venomm@gmail.com>
# Contributor: Uncle Hunto <unclehunto@yahoo.com>
# Contributor: Limao Luo <luolimao+AUR@gmail.com>
@@ -7,7 +8,7 @@
# Contributor: Jamesjon <universales@protonmail.com>
pkgname=peazip-qt-bin
-pkgver=9.1.0
+pkgver=9.2.0
pkgrel=1
pkgdesc='PeaZip file manager and archiver (Qt5)'
arch=('x86_64')
@@ -15,63 +16,44 @@ url='https://peazip.github.io'
license=('LGPL3')
depends=('qt5pas')
options=('!emptydirs')
-optdepends=('p7zip: Command-line file archiver with high compression ratio'
- 'quad: High-performance file compressor that utilizes an advanced LZ-based compression algorithm'
- 'arc: Arc file archiver and compressor'
- 'zpaq: Programmable file compressor, library and utilities'
- 'paq8o: PAQ8 series of archivers, resurrected by new maintainers'
- 'upx: Extendable, high-performance executable packer for several executable formats')
+optdepends=('7-zip: File archiver with a high compression ratio'
+ 'quad: High-performance file compressor that utilizes an advanced LZ-based compression algorithm'
+ 'arc: Arc file archiver and compressor'
+ 'zpaq: Programmable file compressor, library and utilities'
+ 'paq8o: PAQ8 series of archivers, resurrected by new maintainers'
+ 'upx: Extendable, high-performance executable packer for several executable formats')
provides=('peazip')
conflicts=('peazip-gtk2-bin' 'peazip-qt5' 'peazip-qt5-bin')
source=("https://github.com/peazip/PeaZip/releases/download/${pkgver}/peazip-${pkgver}.LINUX.Qt5-1.${CARCH}.rpm")
-sha256sums=('f2abd125f3f50c2f99e007f59940a2a17cd5a26f2b7b064a2dc579d58e92e880')
+sha256sums=('c8ebcacdba92685fd1a769c74a7df224e5dee1c0c63d1f42450e380cf9b7f279')
changelog=changelog.txt
prepare() {
- # Senior Giorgio Tani should definitely reconsider the way he builds his Linux packages: he adds a lot of
- # unnecessary Windows-related files to them. Additionally, he sets wrong permissions on folders: the majority
- # of them are set to 777, whereas it should be 755. So here I'm removing Windows files and setting the
- # appropriate permissions before packaging.
+ rm -r usr/share/peazip/batch/{SendTo,'Windows 11 mini context menu','macOS service menus',*.bat}
+ rm -r usr/share/peazip/batch/freedesktop_integration/KDE-servicemenus/{KDE3*,KDE4*}
+ rm usr/share/peazip/icons/peazip_seven.icl
+ rm -r usr/share/peazip/lang-wincontext
+ rm usr/share/peazip/readme/readme_{Windows,macOS}.txt
+ rm usr/lib/peazip/res/bin/7z/7z.sfx
+ chmod -x usr/lib/peazip/res/bin/7z/Codecs/*.so
+}
- rm -r usr/lib/.build-id
- rm usr/lib/libQt5Pas.so.1
- rm usr/lib/peazip/libQt5Pas.so.1
- # 7z.sfx is a Windows executable
- rm usr/lib/peazip/res/bin/7z/7z.sfx
+package() {
+ local usr_share_peazip='usr/share/peazip'
- local sharedUsr=usr/share
- local sharedPeaZip="${sharedUsr}/peazip"
- # Windows related stuff
- rm "${sharedPeaZip}/batch/"*.bat
- rm -r "${sharedPeaZip}/batch/SendTo"
- rm -r "${sharedPeaZip}/batch/Windows 11 mini context menu"
- rm "${sharedPeaZip}/readme/readme_Windows.txt"
- # macOS related stuff
- rm -r "${sharedPeaZip}/batch/macOS service menus"
- rm "${sharedPeaZip}/readme/readme_macOS.txt"
- # KDE 3? You must be kidding.
- rm -r "${sharedPeaZip}/batch/freedesktop_integration/KDE-servicemenus/KDE3-konqueror"
- # KDE 4 is not supported on Arch since 2015-12-12 (https://archlinux.org/news/dropping-plasma-4/)
- rm -r "${sharedPeaZip}/batch/freedesktop_integration/KDE-servicemenus/KDE4-dolphin"
+ install -dm755 "${pkgdir}/usr/"{bin,lib/peazip,share/{doc/peazip,peazip,licenses/peazip/}}
- # setting correct permissions
- chmod 755 usr && chmod 755 usr/bin
- chmod 755 usr/lib && chmod 755 usr/lib/peazip
- chmod 755 usr/lib/peazip/res && chmod -R 755 usr/lib/peazip/res/bin
- chmod -x usr/lib/peazip/res/bin/7z/Codecs/*.so
- chmod 755 "${sharedUsr}"
- for subDir in "${sharedUsr}"/*; do chmod 755 "${subDir}"; done
- chmod 755 "${sharedUsr}/doc/peazip"
- for subDir in "${sharedPeaZip}"/*; do
- if [ -d "${subDir}" ]; then
- chmod 755 $(find "${subDir}" -type d)
- fi
- done
-}
+ cp -a usr/bin/peazip "${pkgdir}/usr/bin/"
-package() {
- mkdir "${pkgdir}/usr"
- cp -aR usr/bin/ "${pkgdir}/usr"
- cp -aR usr/lib/ "${pkgdir}/usr"
- cp -aR usr/share/ "${pkgdir}/usr"
+ cp -ar usr/lib/peazip/{peazip,pea,res} -t "${pkgdir}/usr/lib/peazip/"
+
+ mv "${usr_share_peazip}"/copying/* "${pkgdir}/usr/share/licenses/peazip"
+
+ mv "${usr_share_peazip}/peazip_help.pdf" "${pkgdir}/usr/share/doc/peazip/help.pdf"
+
+ mv "${usr_share_peazip}/readme/readme_Linux.txt" "${pkgdir}/usr/share/doc/peazip/readme.txt"
+ rm -r "${usr_share_peazip}/readme/"
+
+ cp -ar "${usr_share_peazip}" -t "${pkgdir}/usr/share"
+ cp -ar usr/share/{pixmaps,applications} -t "${pkgdir}/usr/share/"
}
diff --git a/changelog.txt b/changelog.txt
index f0d8c0da8119..9ac2b0058b79 100644
--- a/changelog.txt
+++ b/changelog.txt
@@ -1,3 +1,13 @@
+* Tue May 23 2023 Siavash Askari Nasr - 9.5.0
+ PeaZip 9.2.0 improves the GUI with more customization options for address bar and tab
+ bar, and re-organizes support section, with easier access to online resources,
+ documentation, issue tracker, and to settings relevant to privacy and security. Under
+ the hood the support for editing non-canonical archive types was improved, and it is now
+ possible to try different methods to manage unsupported file types. On Windows, McMilk
+ codecs and sfx modules were updated, to support extra compression methods for .7z format
+ (Brotli, FLZMA2, Lizard, Zstandard...), and on all platforms it is now possible to set
+ an alias for 7z / p7zip backend to easily switch between alternative binaries.
+
* Sat Mar 11 2023 Vladimir Svyatski <vsvyatski@yandex.ru> - 9.1.0-1
PeaZip 9.1.0 brings a major restyle in application's look & feel and themes, and many
usability improvements for the file manager, and archiving/extraction screens.
diff --git a/prepare_pkg.sh b/prepare_pkg.sh
new file mode 100755
index 000000000000..b050b8e9150d
--- /dev/null
+++ b/prepare_pkg.sh
@@ -0,0 +1,7 @@
+#!/usr/bin/env bash
+
+updpkgsums
+
+makepkg --printsrcinfo > .SRCINFO
+
+makepkg --install
diff --git a/update-srcinfo.sh b/update-srcinfo.sh
deleted file mode 100644
index 4aeb074ad381..000000000000
--- a/update-srcinfo.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-currentDir=$(dirname "$0")
-
-makepkg --printsrcinfo -p "${currentDir}/PKGBUILD" >"${currentDir}/.SRCINFO"