summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYamashita Ren2016-04-29 01:17:48 +0200
committerYamashita Ren2016-04-29 01:17:48 +0200
commit336e899166d0dd19472f4e01ed26f186eea71e78 (patch)
tree585d3dd4e4b550474a3e0e66293079a44dcb2566
downloadaur-336e899166d0dd19472f4e01ed26f186eea71e78.tar.gz
Initial import.
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD33
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0fa0e8b64b73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Thu Apr 28 23:17:35 UTC 2016
+pkgbase = peazip-qt-opensuse-latest
+ pkgdesc = QT archiver utility (openSUSE RPM)
+ pkgver = 6.0.0
+ pkgrel = 1
+ url = http://peazip.sourceforge.net/peazip-linux.html
+ arch = i686
+ arch = x86_64
+ license = Artistic2.0
+ license = LGPL2.1
+ depends = curl
+ depends = desktop-file-utils
+ depends = gmp4
+ depends = libx11
+ depends = ncurses
+ depends = qt4pas
+ optdepends = p7zip
+ optdepends = upx
+ provides = peazip
+ provides = peazip-qt
+ conflicts = peazip
+ conflicts = peazip-gtk2
+ conflicts = peazip-qt
+ source = http://download.opensuse.org/repositories/devel:/languages:/pascal/openSUSE_Factory//
+ sha256sums = SKIP
+
+pkgname = peazip-qt-opensuse-latest
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ad25b82cf2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Yamashita Ren
+# Contributor: Limao Luo <luolimao+AUR@gmail.com>
+# Contributor: TuxSpirit <tuxspirit@archlinux.fr>
+
+pkgname=peazip-qt-opensuse-latest
+arch=(i686 x86_64)
+pkgver=6.0.0
+pkgrel=1
+pkgdesc="QT archiver utility (openSUSE RPM)"
+url=http://peazip.sourceforge.net/peazip-linux.html
+license=(Artistic2.0 LGPL2.1)
+depends=(curl desktop-file-utils gmp4 libx11 ncurses qt4pas)
+optdepends=(p7zip upx)
+provides=(${pkgname%-*-*-*} ${pkgname%-*-*})
+conflicts=(${pkgname%-*-*-*} ${pkgname%-*-*-*}-gtk2 ${pkgname%-*-*})
+if [[ $CARCH == i686 ]]; then _CARCH=i586; else _CARCH=$CARCH; fi
+_repo="http://download.opensuse.org/repositories/devel:/languages:/pascal/openSUSE_Factory/${_CARCH}/"
+_rpm=$(curl ${_repo} | grep peazip | cut -d'"' -f6)
+source=(${_repo}${_rpm})
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"
+ ls peazip*.rpm | cut -d- -f2
+}
+
+package() {
+ cp -R "$srcdir"/usr $pkgdir/
+ cd $pkgdir/usr
+ mv share/doc/packages/peazip share/doc
+ rmdir share/doc/packages
+ mv lib64 lib
+}