summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2015-12-16 17:54:12 -0500
committerAdam Goldsmith2015-12-16 17:54:12 -0500
commit44868acfa5a95e7d6286d37e401ffbd31ea854cc (patch)
tree3232106931a66cfe3ed709032e04ed483f036eca
downloadaur-44868acfa5a95e7d6286d37e401ffbd31ea854cc.tar.gz
Initial commit
working: * getting SDKs * building * transfering via phone not working: * emulation untested: * everything else
-rw-r--r--.SRCINFO34
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD50
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c33a51cadb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = pebble-tool-git
+ pkgdesc = The pebble tool that goes with libpebble2
+ pkgver = v4.0
+ pkgrel = 1
+ url = https://github.com/pebble/pebble-tool
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-libpebble2-git
+ depends = python2-httplib2
+ depends = python2-oauth2client
+ depends = python2-progressbar2-old
+ depends = python2-pyasn1
+ depends = python2-pyasn1-modules
+ depends = python2-pypng
+ depends = python2-pyqrcode
+ depends = python2-requests
+ depends = python2-rsa
+ depends = python2-pyserial
+ depends = python2-six
+ depends = python2-websocket-client
+ depends = python2-wheel
+ depends = python2-colorama
+ optdepends = python2-virtualenv: Required for installing SDK
+ optdepends = arm-none-eabi-gcc: Required for installing SDK
+ optdepends = arm-none-eabi-newlib: Required for installing SDK
+ optdepends = qemu: Emulation support
+ conflicts = pebble-sdk
+ source = git+https://github.com/pebble/pebble-tool.git
+ md5sums = SKIP
+
+pkgname = pebble-tool-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..727e60b886df
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar*
+/pebble-tool/
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7836e5d518f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+pkgname=pebble-tool-git
+pkgver=v4.0
+pkgrel=1
+pkgdesc="The pebble tool that goes with libpebble2"
+arch=('any')
+url="https://github.com/pebble/pebble-tool"
+license=('MIT')
+depends=('python2'
+ 'python2-libpebble2-git'
+ 'python2-httplib2'
+ 'python2-oauth2client'
+ 'python2-progressbar2-old'
+ 'python2-pyasn1'
+ 'python2-pyasn1-modules'
+ 'python2-pypng'
+ 'python2-pyqrcode'
+ 'python2-requests'
+ 'python2-rsa'
+ 'python2-pyserial'
+ 'python2-six'
+ 'python2-websocket-client'
+ 'python2-wheel'
+ 'python2-colorama')
+optdepends=('python2-virtualenv: Required for installing SDK'
+ 'arm-none-eabi-gcc: Required for installing SDK'
+ 'arm-none-eabi-newlib: Required for installing SDK'
+ 'qemu: Emulation support')
+makedepends=('python2-setuptools')
+conflicts=('pebble-sdk')
+source=("git+https://github.com/pebble/pebble-tool.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/pebble-tool"
+ git describe --tags | sed 's/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/pebble-tool"
+ sed -i 's/==.*$//' requirements.txt
+ sed -i 's/==.*'\'',$/'\'',/' setup.py
+}
+
+package() {
+ cd "$srcdir/pebble-tool"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: