summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Walladge2016-08-23 17:41:18 +0930
committerSamuel Walladge2016-08-23 17:41:18 +0930
commit533e8b7f1dd55a4630cc6df38a94218774b46cc0 (patch)
tree427acfaa10695fdbdbb9cfa47a3634f0375f7729
parent98525c53f362a85ed4133e0373b73e4ff997628b (diff)
downloadaur-533e8b7f1dd55a4630cc6df38a94218774b46cc0.tar.gz
update to 0.4.2, now use binary releases from github
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 13 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a616467c3539..48a1fbe1786e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
# Generated by mksrcinfo v8
-# Thu Jun 23 09:54:07 UTC 2016
+# Tue Aug 23 08:10:44 UTC 2016
pkgbase = peco
pkgdesc = Simplistic interactive filtering tool
- pkgver = 0.3.6
+ pkgver = 0.4.2
pkgrel = 1
url = https://github.com/peco/peco
arch = x86_64
arch = i686
license = MIT
- makedepends = go
- makedepends = git
- depends = glibc
- source = https://github.com/peco/peco/archive/v0.3.6.tar.gz
- sha256sums = edc1ec186a0f439ae84071c9e00f68fec6f8fe49efc9b6bb10462e72f7286b23
+ source_x86_64 = https://github.com/peco/peco/releases/download/v0.4.2/peco_linux_amd64.tar.gz
+ md5sums_x86_64 = b20bfaf869e456447d523aca5b05c91c
+ source_i686 = https://github.com/peco/peco/releases/download/v0.4.2/peco_linux_386.tar.gz
+ md5sums_i686 = 5651a014b1c3ad85139c2dd9eb814395
pkgname = peco
diff --git a/PKGBUILD b/PKGBUILD
index 52c4008b4cf8..b27a6649c30e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,22 @@
# Maintainer: Samuel Walladge <swalladge at gmail dot com>
pkgname=peco
-pkgver=0.3.6
+pkgver=0.4.2
pkgrel=1
pkgdesc='Simplistic interactive filtering tool'
arch=('x86_64' 'i686')
url='https://github.com/peco/peco'
license=('MIT')
-makedepends=('go' 'git' )
-depends=('glibc')
-source=("https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('edc1ec186a0f439ae84071c9e00f68fec6f8fe49efc9b6bb10462e72f7286b23')
+source_x86_64=("https://github.com/peco/peco/releases/download/v${pkgver}/peco_linux_amd64.tar.gz")
+source_i686=("https://github.com/peco/peco/releases/download/v${pkgver}/peco_linux_386.tar.gz")
+md5sums_x86_64=('b20bfaf869e456447d523aca5b05c91c')
+md5sums_i686=('5651a014b1c3ad85139c2dd9eb814395')
-prepare() {
- export GOPATH="$srcdir"
- go get github.com/${pkgname}/${pkgname}
-}
-
-build() {
- cd "${pkgname}-${pkgver}/cmd/${pkgname}"
-
- GOPATH="$srcdir" go build
-}
package() {
- cd "${pkgname}-${pkgver}"
+ [[ "$arch" == "x86_64" ]] && cd "${pkgname}_linux_amd64" || cd "${pkgname}_linux_386"
- install -Dm755 "./cmd/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}
# vim:set ts=2 sw=2 et: