summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Wolfer2017-03-11 22:15:29 +0100
committerPhilipp Wolfer2017-03-11 22:15:29 +0100
commit39d652cd79692a8515cd8a33cd767f0460aa5674 (patch)
tree1903d7855aade51953b79426704614f1f90a50bc
parentf1c82f5600577a4778eea4133c512e800e533b21 (diff)
downloadaur-39d652cd79692a8515cd8a33cd767f0460aa5674.tar.gz
New upstream release 1.0.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD28
2 files changed, 23 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eeed8150d13a..f0df4f64127f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Feb 20 23:25:59 UTC 2017
+# Sat Mar 11 21:15:29 UTC 2017
pkgbase = peek
- pkgdesc = An animated GIF recorder
- pkgver = 0.9.1
+ pkgdesc = Simple animated GIF screen recorder with an easy to use interface
+ pkgver = 1.0.0
pkgrel = 1
url = https://github.com/phw/peek
arch = i686
@@ -12,9 +12,12 @@ pkgbase = peek
makedepends = vala
makedepends = gettext
depends = gtk3
+ depends = libkeybinder3
depends = ffmpeg
depends = imagemagick
- source = git+https://github.com/phw/peek.git#tag=v0.9.1
+ optdepends = gst-plugins-good: WebM output under Gnome Shell
+ optdepends = gst-plugins-ugly: MP4 output under Gnome Shell
+ source = git+https://github.com/phw/peek.git#tag=v1.0.0
sha1sums = SKIP
pkgname = peek
diff --git a/PKGBUILD b/PKGBUILD
index aca6de48c02c..56cf818a1811 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,34 @@
# Maintainer: Philipp Wolfer <ph.wolfer@gmail.com>
pkgname=peek
-pkgver=0.9.1
+pkgver=1.0.0
pkgrel=1
-pkgdesc="An animated GIF recorder"
+pkgdesc="Simple animated GIF screen recorder with an easy to use interface"
arch=('i686' 'x86_64')
url="https://github.com/phw/peek"
license=('GPL3')
-depends=(gtk3 ffmpeg imagemagick)
+depends=(gtk3 libkeybinder3 ffmpeg imagemagick)
makedepends=(cmake vala gettext)
+optdepends=(
+ 'gst-plugins-good: WebM output under Gnome Shell'
+ 'gst-plugins-ugly: MP4 output under Gnome Shell'
+)
source=(git+https://github.com/phw/peek.git#tag=v${pkgver})
sha1sums=('SKIP')
build() {
- cd "${srcdir}/peek"
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_TESTS=OFF \
- -DGSETTINGS_COMPILE=OFF .
- make
+ cd "${srcdir}/peek"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTS=ON \
+ -DGSETTINGS_COMPILE=OFF .
+ make
}
check() {
- cd "${srcdir}/peek"
- #make test
+ cd "${srcdir}/peek"
+ #make test
}
package() {
- cd "${srcdir}/peek"
- make DESTDIR=${pkgdir} install
+ cd "${srcdir}/peek"
+ make DESTDIR=${pkgdir} install
}